summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 17:11:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 17:11:59 +0000
commit2a1bf0b3c42ed3499d5ef7c57c61b09e64265133 (patch)
tree66570258b88b38c8a38ccd7a8249a283c6d1bf5d /dev-python/vertex
parentVersion bump. (diff)
downloadgentoo-2-2a1bf0b3c42ed3499d5ef7c57c61b09e64265133.tar.gz
gentoo-2-2a1bf0b3c42ed3499d5ef7c57c61b09e64265133.tar.bz2
gentoo-2-2a1bf0b3c42ed3499d5ef7c57c61b09e64265133.zip
Restrict Jython ABIs. Simplify src_test().
(Portage version: 2.2.0_alpha15_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/vertex')
-rw-r--r--dev-python/vertex/ChangeLog8
-rw-r--r--dev-python/vertex/vertex-0.3.0.ebuild15
2 files changed, 11 insertions, 12 deletions
diff --git a/dev-python/vertex/ChangeLog b/dev-python/vertex/ChangeLog
index 64a467adbbed..de65b2b1fc2d 100644
--- a/dev-python/vertex/ChangeLog
+++ b/dev-python/vertex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/vertex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/ChangeLog,v 1.12 2010/12/26 15:50:00 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/ChangeLog,v 1.13 2011/01/16 17:11:59 arfrever Exp $
+
+ 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ vertex-0.3.0.ebuild:
+ Restrict Jython ABIs.
26 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
vertex-0.3.0.ebuild:
diff --git a/dev-python/vertex/vertex-0.3.0.ebuild b/dev-python/vertex/vertex-0.3.0.ebuild
index 226309f6076e..d24403b62426 100644
--- a/dev-python/vertex/vertex-0.3.0.ebuild
+++ b/dev-python/vertex/vertex-0.3.0.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/vertex-0.3.0.ebuild,v 1.4 2010/12/26 15:50:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/vertex-0.3.0.ebuild,v 1.5 2011/01/16 17:11:59 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
# setup.py uses epsilon.setuphelper.autosetup(), which tries to use
# build-${PYTHON_ABI} directories as packages.
@@ -39,10 +41,3 @@ src_compile() {
# Skip distutils_src_compile to avoid installation of $(python_get_sitedir)/build directory.
:
}
-
-src_test() {
- testing() {
- PYTHONPATH="." trial vertex
- }
- python_execute_function testing
-}