summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-02-22 23:04:42 +0000
committerMarien Zwart <marienz@gentoo.org>2012-02-22 23:04:42 +0000
commita41495aed6d943e92467e2a97347f83c5340309f (patch)
tree0359857bf158a29726880150f9efb92819518d72 /dev-python/translationstring
parentNew ebuild for split-out debug info files (diff)
downloadgentoo-2-a41495aed6d943e92467e2a97347f83c5340309f.tar.gz
gentoo-2-a41495aed6d943e92467e2a97347f83c5340309f.tar.bz2
gentoo-2-a41495aed6d943e92467e2a97347f83c5340309f.zip
Version bump.
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/translationstring')
-rw-r--r--dev-python/translationstring/ChangeLog11
-rw-r--r--dev-python/translationstring/translationstring-1.1.ebuild39
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/translationstring/ChangeLog b/dev-python/translationstring/ChangeLog
index 63bf52970449..45853c7df7db 100644
--- a/dev-python/translationstring/ChangeLog
+++ b/dev-python/translationstring/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/translationstring
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.6 2012/02/08 07:03:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.7 2012/02/22 23:04:42 marienz Exp $
+
+*translationstring-1.1 (22 Feb 2012)
+
+ 22 Feb 2012; Marien Zwart <marienz@gentoo.org> +translationstring-1.1.ebuild:
+ Version bump.
+ Support python 3.
+ Stop building documentation, as upstream's preferred theme does not work
+ offline.
+ Drop unnecessary test dependency.
*translationstring-0.4 (08 Feb 2012)
diff --git a/dev-python/translationstring/translationstring-1.1.ebuild b/dev-python/translationstring/translationstring-1.1.ebuild
new file mode 100644
index 000000000000..c8f13f8f4d54
--- /dev/null
+++ b/dev-python/translationstring/translationstring-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/translationstring-1.1.ebuild,v 1.1 2012/02/22 23:04:42 marienz Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.0 3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Utility library for i18n relied on by various Repoze packages"
+HOMEPAGE="https://github.com/Pylons/translationstring http://pypi.python.org/pypi/translationstring"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt README.txt COPYRIGHT.txt"
+
+src_install() {
+ distutils_src_install
+
+ # Install only the .rst source, as sphinx processing requires a
+ # theme only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs would
+ # not actually work offline). Install into a "docs" subdirectory
+ # so the reference in the README remains correct.
+ docinto docs
+ dodoc docs/*.rst
+}