summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-27 11:49:27 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-27 11:49:27 +0000
commitedbbb7e8519c45df3ecb7a9c69882e3f9db74695 (patch)
tree736c187dbcf3f5e82313b804e628fe992d49d410 /dev-python/traits
parentTake over maintainership. (diff)
downloadgentoo-2-edbbb7e8519c45df3ecb7a9c69882e3f9db74695.tar.gz
gentoo-2-edbbb7e8519c45df3ecb7a9c69882e3f9db74695.tar.bz2
gentoo-2-edbbb7e8519c45df3ecb7a9c69882e3f9db74695.zip
Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/ChangeLog6
-rw-r--r--dev-python/traits/traits-4.3.0-r1.ebuild53
-rw-r--r--dev-python/traits/traits-4.3.0.ebuild59
-rw-r--r--dev-python/traits/traits-4.4.0.ebuild37
4 files changed, 5 insertions, 150 deletions
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index 23d0b6193ea9..6a6f27043317 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/traits
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.49 2015/04/08 08:05:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.50 2015/05/27 11:49:27 mrueg Exp $
+
+ 27 May 2015; Manuel Rüger <mrueg@gentoo.org> -traits-4.3.0-r1.ebuild,
+ -traits-4.3.0.ebuild, -traits-4.4.0.ebuild:
+ Remove old.
08 Apr 2015; Michał Górny <mgorny@gentoo.org> traits-4.3.0-r1.ebuild,
traits-4.4.0.ebuild:
diff --git a/dev-python/traits/traits-4.3.0-r1.ebuild b/dev-python/traits/traits-4.3.0-r1.ebuild
deleted file mode 100644
index 153a35861fe2..000000000000
--- a/dev-python/traits/traits-4.3.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.3.0-r1.ebuild,v 1.5 2015/04/08 08:05:24 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && virtualmake -C docs html
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}
-
-python_install_all() {
- local DOCS=( docs/*.txt )
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/traits/traits-4.3.0.ebuild b/dev-python/traits/traits-4.3.0.ebuild
deleted file mode 100644
index 5dc33d7a53b2..000000000000
--- a/dev-python/traits/traits-4.3.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.3.0.ebuild,v 1.1 2013/04/03 08:13:57 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/numpy )"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- sed -i -e "s/'-O3'//g" setup.py
-}
-
-src_compile() {
- distutils_src_compile
- use doc && virtualmake -C docs html
-}
-
-src_test() {
- testing() {
- local exit_status=0
- pushd $(find build-${PYTHON_ABI}/ -name "${PN}") > /dev/null
- PYTHONPATH=. nosetests -v tests || exit_status=1
- popd > /dev/null
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/traits/traits-4.4.0.ebuild b/dev-python/traits/traits-4.4.0.ebuild
deleted file mode 100644
index b336aab00603..000000000000
--- a/dev-python/traits/traits-4.4.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.4.0.ebuild,v 1.2 2015/04/08 08:05:24 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}