summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-26 15:41:11 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-26 15:41:11 +0000
commit5aeda553a5ebc5841e7ccd12640515f59a257e3c (patch)
treec5e078b7cb86ce7f35cb96b7e067dafb4e5c1212 /dev-python/testtools
parentadd pypy support (diff)
downloadgentoo-2-5aeda553a5ebc5841e7ccd12640515f59a257e3c.tar.gz
gentoo-2-5aeda553a5ebc5841e7ccd12640515f59a257e3c.tar.bz2
gentoo-2-5aeda553a5ebc5841e7ccd12640515f59a257e3c.zip
add pypy support, rm un-needed dep from -1.8.0
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/ChangeLog6
-rw-r--r--dev-python/testtools/testtools-1.7.1.ebuild6
-rw-r--r--dev-python/testtools/testtools-1.8.0.ebuild5
3 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index 7d800cf90891..fa6d5f635123 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.127 2015/07/24 07:29:00 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.128 2015/07/26 15:41:11 idella4 Exp $
+
+ 26 Jul 2015; Ian Delaney <idella4@gentoo.org> testtools-1.7.1.ebuild,
+ testtools-1.8.0.ebuild:
+ add pypy support, rm un-needed dep from -1.8.0
24 Jul 2015; Ian Delaney <idella4@gentoo.org> testtools-1.7.1.ebuild,
testtools-1.8.0.ebuild:
diff --git a/dev-python/testtools/testtools-1.7.1.ebuild b/dev-python/testtools/testtools-1.7.1.ebuild
index f1105f1e48c1..0ecce0ed262d 100644
--- a/dev-python/testtools/testtools-1.7.1.ebuild
+++ b/dev-python/testtools/testtools-1.7.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.7.1.ebuild,v 1.5 2015/05/21 03:40:48 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.7.1.ebuild,v 1.6 2015/07/26 15:41:11 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64"
-IUSE="doc test"
+IUSE="doc"
CDEPEND="
dev-python/extras[${PYTHON_USEDEP}]
diff --git a/dev-python/testtools/testtools-1.8.0.ebuild b/dev-python/testtools/testtools-1.8.0.ebuild
index a969e7143673..038da7135178 100644
--- a/dev-python/testtools/testtools-1.8.0.ebuild
+++ b/dev-python/testtools/testtools-1.8.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.8.0.ebuild,v 1.2 2015/07/24 07:29:00 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-1.8.0.ebuild,v 1.3 2015/07/26 15:41:11 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
inherit distutils-r1
@@ -19,7 +19,6 @@ IUSE="doc test"
CDEPEND="
dev-python/extras[${PYTHON_USEDEP}]
- dev-python/linecache2[${PYTHON_USEDEP}]
dev-python/mimeparse[${PYTHON_USEDEP}]
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]
>=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]