summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-03-02 09:28:58 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-03-02 09:28:58 +0000
commit6cbc2cdbc4ccbbd92c4a56e6b0a31f8c0a2d6f1f (patch)
tree6b58b0c2d67f22ee8712c60acad37e93aeb3afc6 /dev-python/subvertpy
parentFixing headers_more URI madness #406555 (diff)
downloadgentoo-2-6cbc2cdbc4ccbbd92c4a56e6b0a31f8c0a2d6f1f.tar.gz
gentoo-2-6cbc2cdbc4ccbbd92c4a56e6b0a31f8c0a2d6f1f.tar.bz2
gentoo-2-6cbc2cdbc4ccbbd92c4a56e6b0a31f8c0a2d6f1f.zip
Version bump subvertpy to 0.8.10.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/ChangeLog7
-rw-r--r--dev-python/subvertpy/subvertpy-0.8.10.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index efde53ea9451..251430239a0e 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.41 2012/03/02 09:26:28 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.42 2012/03/02 09:28:58 djc Exp $
+
+*subvertpy-0.8.10 (02 Mar 2012)
+
+ 02 Mar 2012; Dirkjan Ochtman <djc@gentoo.org> +subvertpy-0.8.10.ebuild:
+ Version bump to 0.8.10.
02 Mar 2012; Dirkjan Ochtman <djc@gentoo.org> -subvertpy-0.8.5.ebuild,
-subvertpy-0.8.5-r1.ebuild, -subvertpy-0.8.8.ebuild:
diff --git a/dev-python/subvertpy/subvertpy-0.8.10.ebuild b/dev-python/subvertpy/subvertpy-0.8.10.ebuild
new file mode 100644
index 000000000000..4eeb22809a83
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.8.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.8.10.ebuild,v 1.1 2012/03/02 09:28:58 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ test? ( || (
+ dev-lang/python:2.7
+ dev-python/unittest2
+ dev-python/testtools
+ ) )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}