summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:35:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:35:58 +0000
commiteea49eb2bfde6914d52078ca740796bc93a41b4b (patch)
tree81cb26ce820608fb8e236c50991cd7c56889d13f /dev-python/stevedore
parentBump, relax test deps, add py34 (diff)
downloadgentoo-2-eea49eb2bfde6914d52078ca740796bc93a41b4b.tar.gz
gentoo-2-eea49eb2bfde6914d52078ca740796bc93a41b4b.tar.bz2
gentoo-2-eea49eb2bfde6914d52078ca740796bc93a41b4b.zip
Add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog7
-rw-r--r--dev-python/stevedore/stevedore-0.15-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index 8f3ecc99960e..56d9333589b2 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.17 2014/04/01 09:11:46 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.18 2014/06/12 08:35:58 patrick Exp $
+
+*stevedore-0.15-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org> +stevedore-0.15-r1.ebuild:
+ Add py34
01 Apr 2014; Ian Delaney <idella4@gentoo.org> stevedore-0.15.ebuild:
re-add flake8 for test phase
diff --git a/dev-python/stevedore/stevedore-0.15-r1.ebuild b/dev-python/stevedore/stevedore-0.15-r1.ebuild
new file mode 100644
index 000000000000..24573ea449ef
--- /dev/null
+++ b/dev-python/stevedore/stevedore-0.15-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15-r1.ebuild,v 1.1 2014/06/12 08:35:58 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/dreamhost/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ mkdir docs/source/_build || die
+ sphinx-build -b html -c docs/source docs/source/ docs/source/_build
+ fi
+}
+
+python_test() {
+ nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
+ || die "Tests failed under ${EPYTHON}"
+ flake8 stevedore setup.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/. )
+ distutils-r1_python_install_all
+}