summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-11-18 21:38:40 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-11-18 21:38:40 +0000
commit51bb9af8e8ba9e1621a2c4681e88668903ea6d01 (patch)
treefdd454b762294d48b1be57335234506507ac9f53 /dev-python/stevedore
parentVersion bump to first release candidate for 4.85 (diff)
downloadgentoo-2-51bb9af8e8ba9e1621a2c4681e88668903ea6d01.tar.gz
gentoo-2-51bb9af8e8ba9e1621a2c4681e88668903ea6d01.tar.bz2
gentoo-2-51bb9af8e8ba9e1621a2c4681e88668903ea6d01.zip
bup
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog8
-rw-r--r--dev-python/stevedore/stevedore-1.1.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index dcb9f20a40aa..aff35916fda5 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.22 2014/10/26 03:05:49 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.23 2014/11/18 21:38:40 prometheanfire Exp $
+
+*stevedore-1.1.0 (18 Nov 2014)
+
+ 18 Nov 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +stevedore-1.1.0.ebuild:
+ bup
26 Oct 2014; Mike Gilbert <floppym@gentoo.org> stevedore-1.0.0.ebuild:
Unpin dev-python/pillow.
diff --git a/dev-python/stevedore/stevedore-1.1.0.ebuild b/dev-python/stevedore/stevedore-1.1.0.ebuild
new file mode 100644
index 000000000000..dec7a552c644
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-1.1.0.ebuild,v 1.1 2014/11/18 21:38:40 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/dreamhost/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.7.0[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests stevedore || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+
+ distutils-r1_python_install_all
+}