summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2014-07-25 17:27:10 +0000
committerPavlos Ratis <dastergon@gentoo.org>2014-07-25 17:27:10 +0000
commit439b3a498c4ce302a705b3930bb4d29f2be1c591 (patch)
tree9c73990e7313f0d5331f8a482f3545019e66864f /dev-python/ssl-fetch
parentMark stable for all; Drop old. (diff)
downloadgentoo-2-439b3a498c4ce302a705b3930bb4d29f2be1c591.tar.gz
gentoo-2-439b3a498c4ce302a705b3930bb4d29f2be1c591.tar.bz2
gentoo-2-439b3a498c4ce302a705b3930bb4d29f2be1c591.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x3A051746)
Diffstat (limited to 'dev-python/ssl-fetch')
-rw-r--r--dev-python/ssl-fetch/ChangeLog7
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/ssl-fetch/ChangeLog b/dev-python/ssl-fetch/ChangeLog
index d4a3899af002..de1b14c1ea1b 100644
--- a/dev-python/ssl-fetch/ChangeLog
+++ b/dev-python/ssl-fetch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ssl-fetch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ChangeLog,v 1.12 2014/07/20 12:15:12 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ChangeLog,v 1.13 2014/07/25 17:27:10 dastergon Exp $
+
+*ssl-fetch-0.2.1 (25 Jul 2014)
+
+ 25 Jul 2014; Pavlos Ratis <dastergon@gentoo.org> +ssl-fetch-0.2.1.ebuild:
+ version bump
20 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ssl-fetch-0.2.ebuild:
Keyworded on alpha, bug #509628
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild
new file mode 100644
index 000000000000..18e4eace0f20
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild,v 1.1 2014/07/25 17:27:10 dastergon Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A small convinience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="https://github.com/dol-sen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~x86"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is beta software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change in these early versions."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
+ einfo
+}