summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-27 00:36:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-27 00:36:54 +0000
commit5489541e1755f6b681288d0f4c6cdd3da9b4dc08 (patch)
treeda3eadc320c56ef6bc618651f1971aa34a0308ef /dev-python/sqlalchemy
parentVersion bump. (diff)
downloadgentoo-2-5489541e1755f6b681288d0f4c6cdd3da9b4dc08.tar.gz
gentoo-2-5489541e1755f6b681288d0f4c6cdd3da9b4dc08.tar.bz2
gentoo-2-5489541e1755f6b681288d0f4c6cdd3da9b4dc08.zip
Version bump.
(Portage version: 15152-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/ChangeLog8
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-0.5.7.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/sqlalchemy/ChangeLog b/dev-python/sqlalchemy/ChangeLog
index 8a5e18ee3f07..dd1fc9db8d03 100644
--- a/dev-python/sqlalchemy/ChangeLog
+++ b/dev-python/sqlalchemy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sqlalchemy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy/ChangeLog,v 1.32 2009/12/20 12:30:28 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy/ChangeLog,v 1.33 2009/12/27 00:36:54 arfrever Exp $
+
+*sqlalchemy-0.5.7 (27 Dec 2009)
+
+ 27 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sqlalchemy-0.5.7.ebuild:
+ Version bump.
20 Dec 2009; Fabian Groffen <grobian@gentoo.org> sqlalchemy-0.5.6.ebuild:
Merged keywords from Prefix
diff --git a/dev-python/sqlalchemy/sqlalchemy-0.5.7.ebuild b/dev-python/sqlalchemy/sqlalchemy-0.5.7.ebuild
new file mode 100644
index 000000000000..d5e499640256
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-0.5.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlalchemy/sqlalchemy-0.5.7.ebuild,v 1.1 2009/12/27 00:36:54 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P=SQLAlchemy-${PV/_}
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper."
+HOMEPAGE="http://www.sqlalchemy.org/ http://pypi.python.org/pypi/SQLAlchemy"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples firebird mssql mysql postgres +sqlite test"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="firebird? ( dev-python/kinterbasdb )
+ mssql? ( dev-python/pymssql )
+ mysql? ( dev-python/mysql-python )
+ postgres? (
+ >=dev-python/psycopg-2
+ )
+ sqlite? (
+ >=dev-db/sqlite-3.3.13
+ || ( >=dev-lang/python-2.5[sqlite] dev-python/pysqlite )
+ )"
+
+DEPEND="dev-python/setuptools
+ test? (
+ >=dev-db/sqlite-3.3.13
+ >=dev-python/nose-0.10.4
+ || ( >=dev-lang/python-2.5[sqlite] dev-python/pysqlite )
+ )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}