summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
commit8b0de2854b90f275160eb5d068717f5e217739b1 (patch)
treef52504be46ffea88b90590fe18b64681c4777c52 /dev-python/sip
parentA=-fix, try->die, tab-fixes, stylefixes, ... (diff)
downloadgentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.gz
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.bz2
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-2.4.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/sip/sip-2.4.ebuild b/dev-python/sip/sip-2.4.ebuild
index ae62bac580be..cbd6db6886c1 100644
--- a/dev-python/sip/sip-2.4.ebuild
+++ b/dev-python/sip/sip-2.4.ebuild
@@ -1,27 +1,21 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: tools@cvs.gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-2.4.ebuild,v 1.2 2001/08/11 20:35:57 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-2.4.ebuild,v 1.3 2001/11/10 12:14:29 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
-SRC_URI="http://www.river-bank.demon.co.uk/software/"${A}
+SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
HOMEPAGE="http://www.thekompany.com/projects/pykde/"
DEPEND="virtual/python"
src_compile(){
- try ./configure --prefix=/usr
- try emake
+ ./configure --prefix=/usr || die
+ emake || die
}
src_install() {
- try emake DESTDIR=${D} install
- dodoc AUTHORS
- dodoc COPYING
- dodoc NEWS
- dodoc README
- dodoc THANKS
- dodoc TODO
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING NEWS README THANKS TODO
}