summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-01-02 17:59:25 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-01-02 17:59:25 +0000
commit72c1123c42fbc314ed95259769d30a58481cfd47 (patch)
tree9eb2fcb14e8a964beacf2f5b78247520d6d8e8ed /dev-python/simpletal
parentMove from net-zope to dev-python, bug 72252. (Manifest recommit) (diff)
downloadgentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.tar.gz
gentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.tar.bz2
gentoo-2-72c1123c42fbc314ed95259769d30a58481cfd47.zip
Move from net-zope to dev-python, bug 72252.
Diffstat (limited to 'dev-python/simpletal')
-rw-r--r--dev-python/simpletal/ChangeLog20
-rw-r--r--dev-python/simpletal/files/digest-simpletal-3.111
-rw-r--r--dev-python/simpletal/files/digest-simpletal-3.91
-rw-r--r--dev-python/simpletal/metadata.xml5
-rw-r--r--dev-python/simpletal/simpletal-3.11.ebuild44
-rw-r--r--dev-python/simpletal/simpletal-3.9.ebuild41
6 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/simpletal/ChangeLog b/dev-python/simpletal/ChangeLog
new file mode 100644
index 000000000000..ffd6e5324d65
--- /dev/null
+++ b/dev-python/simpletal/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for dev-python/simpletal
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.1 2005/01/02 17:56:57 kloeri Exp $
+
+*simpletal-3.11 (02 Jan 2005)
+
+ 02 Jan 2005; Bryan Østergaard <kloeri@gentoo.org> +metadata.xml,
+ +simpletal-3.11.ebuild, +simpletal-3.9.ebuild:
+ Move from net-zope to dev-python, bug 72252.
+
+*simpletal-3.11 (09 Nov 2004)
+
+ 09 Nov 2004; Radoslaw Stachowiak <radek@gentoo.org>
+ +simpletal-3.11.ebuild:
+ New version release. Also added html documentation to ebuild.
+
+ 12 May 2004; Jodok Batlogg <batlogg@gentoo.org>; :
+ initial import, user submitted ebuild, fixes #50278, thanks to Iain Smith
+ <gentoo@iesmith.net>
+
diff --git a/dev-python/simpletal/files/digest-simpletal-3.11 b/dev-python/simpletal/files/digest-simpletal-3.11
new file mode 100644
index 000000000000..229be1663745
--- /dev/null
+++ b/dev-python/simpletal/files/digest-simpletal-3.11
@@ -0,0 +1 @@
+MD5 fe37ab089165625738a10736a573b0b3 SimpleTAL-3.11.tar.gz 84558
diff --git a/dev-python/simpletal/files/digest-simpletal-3.9 b/dev-python/simpletal/files/digest-simpletal-3.9
new file mode 100644
index 000000000000..81c4bf7dd71f
--- /dev/null
+++ b/dev-python/simpletal/files/digest-simpletal-3.9
@@ -0,0 +1 @@
+MD5 08a539e94b4693f3072cdab124e8ade9 SimpleTAL-3.9.tar.gz 56859
diff --git a/dev-python/simpletal/metadata.xml b/dev-python/simpletal/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/simpletal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/simpletal/simpletal-3.11.ebuild b/dev-python/simpletal/simpletal-3.11.ebuild
new file mode 100644
index 000000000000..5c917a501741
--- /dev/null
+++ b/dev-python/simpletal/simpletal-3.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-3.11.ebuild,v 1.1 2005/01/02 17:56:57 kloeri Exp $
+
+IUSE=""
+
+MY_P=SimpleTAL
+
+inherit distutils
+
+DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}-${PV}.tar.gz"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/"
+DEPEND="virtual/python"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+S=${WORKDIR}/${MY_P}-${PV}
+
+src_install() {
+ distutils_src_install
+
+ dohtml documentation/html/*
+
+ docinto examples/basic
+ dodoc examples/basic/basic-example.py
+ dodoc examples/basic/basic.html
+
+ docinto examples/cgi-example
+ dodoc examples/cgi-example/simple-cgi.py
+ dodoc examples/cgi-example/fields.html
+ dodoc examples/cgi-example/results.html
+
+ docinto examples/metal-example
+ dodoc examples/metal-example/metal-example.py
+ dodoc examples/metal-example/macro.html
+ dodoc examples/metal-example/page.html
+
+ docinto examples/structure-example
+ dodoc examples/structure-example/structure-example.py
+ dodoc examples/structure-example/structure.html
+
+}
diff --git a/dev-python/simpletal/simpletal-3.9.ebuild b/dev-python/simpletal/simpletal-3.9.ebuild
new file mode 100644
index 000000000000..895045de08a1
--- /dev/null
+++ b/dev-python/simpletal/simpletal-3.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-3.9.ebuild,v 1.1 2005/01/02 17:56:57 kloeri Exp $
+
+IUSE=""
+
+MY_P=SimpleTAL
+
+inherit distutils
+
+DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}-${PV}.tar.gz"
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/"
+DEPEND="virtual/python"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+S=${WORKDIR}/${MY_P}-${PV}
+
+src_install() {
+ distutils_src_install
+
+ docinto examples/basic
+ dodoc examples/basic/basic-example.py
+ dodoc examples/basic/basic.html
+
+ docinto examples/cgi-example
+ dodoc examples/cgi-example/simple-cgi.py
+ dodoc examples/cgi-example/fields.html
+ dodoc examples/cgi-example/results.html
+
+ docinto examples/metal-example
+ dodoc examples/metal-example/metal-example.py
+ dodoc examples/metal-example/macro.html
+ dodoc examples/metal-example/page.html
+
+ docinto examples/structure-example
+ dodoc examples/structure-example/structure-example.py
+ dodoc examples/structure-example/structure.html
+}