summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-15 11:23:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-15 11:23:11 +0000
commit52edbe46211374873aa14659eaf3d6188f3aabaa (patch)
treebd7089eb6d53e303d218180ef9809a2a1b42f50f /dev-python/shiboken
parentVersion bump (diff)
downloadgentoo-2-52edbe46211374873aa14659eaf3d6188f3aabaa.tar.gz
gentoo-2-52edbe46211374873aa14659eaf3d6188f3aabaa.tar.bz2
gentoo-2-52edbe46211374873aa14659eaf3d6188f3aabaa.zip
Version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog9
-rw-r--r--dev-python/shiboken/shiboken-1.1.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 9e3a2e7a927e..0299fb399cdc 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/shiboken
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.15 2011/12/27 09:06:01 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.16 2012/01/15 11:23:11 hwoarang Exp $
+
+*shiboken-1.1.0 (15 Jan 2012)
+
+ 15 Jan 2012; Markos Chandras <hwoarang@gentoo.org> +shiboken-1.1.0.ebuild:
+ Version bump
27 Dec 2011; Patrick Lauer <patrick@gentoo.org> -shiboken-1.0.9.ebuild:
Remove unneeded version
diff --git a/dev-python/shiboken/shiboken-1.1.0.ebuild b/dev-python/shiboken/shiboken-1.1.0.ebuild
new file mode 100644
index 000000000000..07a06e0e2077
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.0.ebuild,v 1.1 2012/01/15 11:23:11 hwoarang Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python versionator cmake-utils
+
+MY_PV=$(replace_version_separator '_' '~')
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+DEPEND=">=dev-python/apiextractor-0.10.10
+ >=dev-python/generatorrunner-0.6.16
+ >=x11-libs/qt-core-4.7.0"
+RDEPEND="${DEPEND}
+ !dev-python/boostpythongenerator"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.9-fix-pkgconfig.patch" )
+
+DOCS=( ChangeLog )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}