summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-29 10:24:37 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-29 10:24:37 +0000
commit2f23d246e763867f12d9ba5f890db60359986d55 (patch)
tree2ac4444da244bc7daf71a1fdf1d56ce496202163 /dev-python/setuptools
parentbump to keep in sync with llvm releases; code is identical (diff)
downloadgentoo-2-2f23d246e763867f12d9ba5f890db60359986d55.tar.gz
gentoo-2-2f23d246e763867f12d9ba5f890db60359986d55.tar.bz2
gentoo-2-2f23d246e763867f12d9ba5f890db60359986d55.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog7
-rw-r--r--dev-python/setuptools/setuptools-17.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 1cd4ed6ca17c..6bcc3d1fcfda 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.279 2015/05/19 18:06:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.280 2015/05/29 10:24:37 jlec Exp $
+
+*setuptools-17.0 (29 May 2015)
+
+ 29 May 2015; Justin Lecher <jlec@gentoo.org> +setuptools-17.0.ebuild:
+ Version Bump
*setuptools-16.0 (19 May 2015)
diff --git a/dev-python/setuptools/setuptools-17.0.ebuild b/dev-python/setuptools/setuptools-17.0.ebuild
new file mode 100644
index 000000000000..6baa5ea57224
--- /dev/null
+++ b/dev-python/setuptools/setuptools-17.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-17.0.ebuild,v 1.1 2015/05/29 10:24:37 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}