summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-10 01:20:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-10 01:20:13 +0000
commite2099c8e6a51f82951140231d2e90ae2fbf0b259 (patch)
tree64f4d9b874ae457ee3348d982544e6bdc1f97a23 /dev-python/setuptools/files
parentInitial 2.6.31 release including the fbcondecor patch,, a paoatch to enable c... (diff)
downloadgentoo-2-e2099c8e6a51f82951140231d2e90ae2fbf0b259.tar.gz
gentoo-2-e2099c8e6a51f82951140231d2e90ae2fbf0b259.tar.bz2
gentoo-2-e2099c8e6a51f82951140231d2e90ae2fbf0b259.zip
Version bump.
(Portage version: 14221-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setuptools/files')
-rw-r--r--dev-python/setuptools/files/distribute-0.6.1-USER_SITE.patch25
-rw-r--r--dev-python/setuptools/files/distribute-0.6.1-provide_setuptools.patch22
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/setuptools/files/distribute-0.6.1-USER_SITE.patch b/dev-python/setuptools/files/distribute-0.6.1-USER_SITE.patch
new file mode 100644
index 000000000000..990160238aaf
--- /dev/null
+++ b/dev-python/setuptools/files/distribute-0.6.1-USER_SITE.patch
@@ -0,0 +1,25 @@
+http://bitbucket.org/tarek/distribute/changeset/2545492098ff/
+
+--- distribute_setup.py
++++ distribute_setup.py
+@@ -13,7 +13,11 @@ the appropriate options to ``use_setupto
+
+ This file can also be run as a script to install or upgrade setuptools.
+ """
+-from site import USER_SITE
++try:
++ from site import USER_SITE
++except ImportError:
++ USER_SITE = None
++
+ import sys
+ import os
+ import time
+@@ -199,7 +203,7 @@ def _under_prefix(location):
+ if len(args) > index:
+ top_dir = args[index+1]
+ return location.startswith(top_dir)
+- elif option == '--user':
++ elif option == '--user' and USER_SITE is not None:
+ return location.startswith(USER_SITE)
+ return True
diff --git a/dev-python/setuptools/files/distribute-0.6.1-provide_setuptools.patch b/dev-python/setuptools/files/distribute-0.6.1-provide_setuptools.patch
new file mode 100644
index 000000000000..19ab1e4d9506
--- /dev/null
+++ b/dev-python/setuptools/files/distribute-0.6.1-provide_setuptools.patch
@@ -0,0 +1,22 @@
+--- setup.py
++++ setup.py
+@@ -28,7 +28,7 @@
+ before_install()
+
+ dist = setup(
+- name="distribute",
++ name="setuptools",
+ version=VERSION,
+ description="Download, build, install, upgrade, and uninstall Python "
+ "packages -- easily!",
+--- setuptools/package_index.py
++++ setuptools/package_index.py
+@@ -143,7 +143,7 @@
+ yield urlparse.urljoin(url, htmldecode(match.group(1)))
+
+ user_agent = "Python-urllib/%s distribute/%s" % (
+- urllib2.__version__, require('distribute')[0].version
++ urllib2.__version__, require('setuptools')[0].version
+ )
+
+