summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-08 14:28:03 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-08 14:28:03 +0000
commit78bd4b1b7a5bd029aea19b1916a7b25ae0ae7817 (patch)
treed3feba48c7313e1624203c37b4380e0d786ae87b /dev-python/scrapy
parentold (diff)
downloadgentoo-2-78bd4b1b7a5bd029aea19b1916a7b25ae0ae7817.tar.gz
gentoo-2-78bd4b1b7a5bd029aea19b1916a7b25ae0ae7817.tar.bz2
gentoo-2-78bd4b1b7a5bd029aea19b1916a7b25ae0ae7817.zip
from fix by /issues/788 by owner @ github, update dep w3lib, delete superfluous python_prepare_all(), correction to test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/scrapy')
-rw-r--r--dev-python/scrapy/ChangeLog6
-rw-r--r--dev-python/scrapy/scrapy-0.24.1.ebuild17
2 files changed, 10 insertions, 13 deletions
diff --git a/dev-python/scrapy/ChangeLog b/dev-python/scrapy/ChangeLog
index 8bd5f5f0b388..524e0b87caf0 100644
--- a/dev-python/scrapy/ChangeLog
+++ b/dev-python/scrapy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/scrapy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.23 2014/07/08 08:54:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/ChangeLog,v 1.24 2014/07/08 14:28:03 idella4 Exp $
+
+ 08 Jul 2014; Ian Delaney <idella4@gentoo.org> scrapy-0.24.1.ebuild:
+ from fix by /issues/788 by owner @ github, update dep w3lib, delete
+ superfluous python_prepare_all(), correction to test phase
*scrapy-0.24.1 (08 Jul 2014)
diff --git a/dev-python/scrapy/scrapy-0.24.1.ebuild b/dev-python/scrapy/scrapy-0.24.1.ebuild
index ae68fdc624b3..38380a841879 100644
--- a/dev-python/scrapy/scrapy-0.24.1.ebuild
+++ b/dev-python/scrapy/scrapy-0.24.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.24.1.ebuild,v 1.1 2014/07/08 08:54:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scrapy/scrapy-0.24.1.ebuild,v 1.2 2014/07/08 14:28:03 idella4 Exp $
EAPI=5
@@ -29,7 +29,7 @@ RDEPEND=">=dev-python/six-1.5.2[${PYTHON_USEDEP}]
>=dev-python/twisted-conch-10.0.0[${PYTHON_USEDEP}]
>=dev-python/twisted-mail-10.0.0[${PYTHON_USEDEP}]
>=dev-python/twisted-web-10.0.0[${PYTHON_USEDEP}]
- >=dev-python/w3lib-1.2[${PYTHON_USEDEP}]
+ >=dev-python/w3lib-1.6[${PYTHON_USEDEP}]
dev-python/queuelib[${PYTHON_USEDEP}]
>=dev-python/cssselect-0.9[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -42,18 +42,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
>=net-proxy/mitmproxy-0.10[${PYTHON_USEDEP}]
net-ftp/vsftpd )"
-# pytest-twisted listed as a test dep but not in portage
+# pytest-twisted listed as a test dep but not in portage.
+# Testsuite currently survives without it, so appears optional
REQUIRED_USE="test? ( ssl boto )"
-python_prepare_all() {
- # Skip failing tests; https://github.com/scrapy/scrapy/issues/788
- # There's 1 doctest failure that remains on being run.
- sed -e s':test_ajax_url:_&:' -i scrapy/tests/test_http_request.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_compile_all() {
if use doc; then
PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
@@ -61,7 +54,7 @@ python_compile_all() {
}
python_test() {
- py.test --twisted ${PN} || die "tests failed"
+ py.test ${PN} || die "tests failed"
}
python_install_all() {