summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-07 05:54:56 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-07 05:54:56 +0000
commit419d0fcfeb8565133c1e7cd1865f287f635c8b2a (patch)
tree373e07c1ea133d9ee9035263f4184e8cc8759a52 /dev-python/rhpxl
parentBump. (diff)
downloadgentoo-2-419d0fcfeb8565133c1e7cd1865f287f635c8b2a.tar.gz
gentoo-2-419d0fcfeb8565133c1e7cd1865f287f635c8b2a.tar.bz2
gentoo-2-419d0fcfeb8565133c1e7cd1865f287f635c8b2a.zip
Force on DDC for radeon driver, so we get valid modes.
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'dev-python/rhpxl')
-rw-r--r--dev-python/rhpxl/ChangeLog6
-rw-r--r--dev-python/rhpxl/files/0.32-use-radeon-ddc.patch17
-rw-r--r--dev-python/rhpxl/rhpxl-0.32.ebuild10
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-python/rhpxl/ChangeLog b/dev-python/rhpxl/ChangeLog
index 2f17238df61c..f748c007c02e 100644
--- a/dev-python/rhpxl/ChangeLog
+++ b/dev-python/rhpxl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rhpxl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/ChangeLog,v 1.1 2006/09/05 21:20:35 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/ChangeLog,v 1.2 2006/09/07 05:54:56 dberkholz Exp $
+
+ 07 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/0.32-use-radeon-ddc.patch, rhpxl-0.32.ebuild:
+ Force on DDC for radeon driver, so we get valid modes.
*rhpxl-0.32 (05 Sep 2006)
diff --git a/dev-python/rhpxl/files/0.32-use-radeon-ddc.patch b/dev-python/rhpxl/files/0.32-use-radeon-ddc.patch
new file mode 100644
index 000000000000..60b5e90fd975
--- /dev/null
+++ b/dev-python/rhpxl/files/0.32-use-radeon-ddc.patch
@@ -0,0 +1,17 @@
+Index: rhpxl/xhwstate.py
+===================================================================
+RCS file: /usr/local/CVS/rhpxl/rhpxl/xhwstate.py,v
+retrieving revision 1.32
+diff -u -b -B -r1.32 xhwstate.py
+--- rhpxl/xhwstate.py 25 Aug 2006 17:26:31 -0000 1.32
++++ rhpxl/xhwstate.py 7 Sep 2006 05:50:35 -0000
+@@ -404,6 +404,9 @@
+ # UseFBDev on at cards on ppc
+ if rhpl.getArch() == "ppc" and driver in ("radeon", "r128", "ati"):
+ self.videocard_options.append(("UseFBDev", "true"))
++ # radeon driver needs to use DDC, otherwise it comes up with invalid modes
++ if driver in ("radeon", "ati"):
++ self.videocard_options.append(("DDCMode", "true"))
+
+ def set_videocard_ram(self, ram):
+ self.video_ram = ram
diff --git a/dev-python/rhpxl/rhpxl-0.32.ebuild b/dev-python/rhpxl/rhpxl-0.32.ebuild
index 78acac90f44d..3bae77f94345 100644
--- a/dev-python/rhpxl/rhpxl-0.32.ebuild
+++ b/dev-python/rhpxl/rhpxl-0.32.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/rhpxl-0.32.ebuild,v 1.1 2006/09/05 21:20:35 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/rhpxl-0.32.ebuild,v 1.2 2006/09/07 05:54:56 dberkholz Exp $
-inherit rpm
+inherit eutils rpm
# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
# tarball out of it
@@ -25,6 +25,12 @@ RDEPEND="dev-lang/python
DEPEND="${RDEPEND}
sys-devel/gettext"
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-use-radeon-ddc.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}