summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-06 06:13:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-06 06:13:13 +0000
commit4792223f9102e94aa284553066dd93167c7724e4 (patch)
tree4555a049da6eee4e802d7439e3fa1b504da4f473 /dev-python/redis-py
parentCleanup. (diff)
downloadgentoo-2-4792223f9102e94aa284553066dd93167c7724e4.tar.gz
gentoo-2-4792223f9102e94aa284553066dd93167c7724e4.tar.bz2
gentoo-2-4792223f9102e94aa284553066dd93167c7724e4.zip
Version bump and keyword amd64-linux and x86-linux
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/ChangeLog9
-rw-r--r--dev-python/redis-py/redis-py-2.9.1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/dev-python/redis-py/ChangeLog b/dev-python/redis-py/ChangeLog
index 8374894bb54f..6d0ab752896d 100644
--- a/dev-python/redis-py/ChangeLog
+++ b/dev-python/redis-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/redis-py
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/ChangeLog,v 1.42 2013/09/05 18:46:37 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/ChangeLog,v 1.43 2014/02/06 06:13:13 bicatali Exp $
+
+*redis-py-2.9.1 (06 Feb 2014)
+
+ 06 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> +redis-py-2.9.1.ebuild:
+ Version bump and keyword amd64-linux and x86-linux
05 Sep 2013; Michał Górny <mgorny@gentoo.org> redis-py-2.7.2-r1.ebuild,
redis-py-2.7.4.ebuild, redis-py-2.7.5.ebuild, redis-py-2.7.6.ebuild:
diff --git a/dev-python/redis-py/redis-py-2.9.1.ebuild b/dev-python/redis-py/redis-py-2.9.1.ebuild
new file mode 100644
index 000000000000..2c7c2a8255ee
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/redis-py-2.9.1.ebuild,v 1.1 2014/02/06 06:13:13 bicatali Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="http://github.com/andymccurdy/redis-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-db/redis )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable pubsub and encoding tests, they do not seem to support
+ # UNIX socket connectivity.
+ sed -i -e '/PubSub/d' -e '/Encoding/d' \
+ -e '/use_hiredis:/d' tests/__init__.py || die
+
+ # Make sure that tests will be used from BUILD_DIR rather than cwd.
+ mv tests tests-hidden || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use test; then
+ cp -r tests-hidden "${BUILD_DIR}"/tests || die
+ fi
+}
+
+src_test() {
+# local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local pidfile=${T}/redis-${EPYTHON}.pid
+ local sock=${T}/redis-${EPYTHON}.sock
+
+ sed -i -e "s:port=6379:unix_socket_path=\"${sock}\":" \
+ "${BUILD_DIR}"/tests/*.py || die
+
+ # XXX: find a way to make sure it is killed
+
+ "${EPREFIX}"/usr/sbin/redis-server \
+ --pidfile "${pidfile}" \
+ --port 0 \
+ --unixsocket "${sock}" \
+ --daemonize yes || die
+ PYTHONPATH="${PYTHONPATH}:${BUILD_DIR}" \
+ esetup.py test
+ kill "$(<"${pidfile}")"
+}