summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-24 20:24:33 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-24 20:24:33 +0000
commit072cd3bc85b1bc947f061c0e2b7b5d55cd94e143 (patch)
tree39cf8468ad4938c3dc8e44eada98de7d9a92cc7c /dev-python/python-xlib
parentSet missing empty RDEPEND. (diff)
downloadgentoo-2-072cd3bc85b1bc947f061c0e2b7b5d55cd94e143.tar.gz
gentoo-2-072cd3bc85b1bc947f061c0e2b7b5d55cd94e143.tar.bz2
gentoo-2-072cd3bc85b1bc947f061c0e2b7b5d55cd94e143.zip
Migrate to distutils-r1. Install HTML docs only.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/python-xlib')
-rw-r--r--dev-python/python-xlib/ChangeLog7
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1-r2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/python-xlib/ChangeLog b/dev-python/python-xlib/ChangeLog
index 0eee5b66c3c7..f518b2016bce 100644
--- a/dev-python/python-xlib/ChangeLog
+++ b/dev-python/python-xlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-xlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.39 2013/02/05 11:48:32 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.40 2013/02/24 20:24:33 mgorny Exp $
+
+*python-xlib-0.15_rc1-r2 (24 Feb 2013)
+
+ 24 Feb 2013; Michał Górny <mgorny@gentoo.org> +python-xlib-0.15_rc1-r2.ebuild:
+ Migrate to distutils-r1. Install HTML docs only.
05 Feb 2013; Ian Delaney <idella4@gentoo.org> +files/defs,
python-xlib-0.15_rc1-r1.ebuild:
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1-r2.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1-r2.ebuild
new file mode 100644
index 000000000000..b6cea6e0bf83
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1-r2.ebuild,v 1.1 2013/02/24 20:24:33 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="http://python-xlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+python_prepare_all() {
+ sed -e 's:make:$(MAKE):g' -i doc/Makefile || die
+ cp -r "${FILESDIR}"/defs doc/src/ || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+ VARTEXFONTS="${T}"/fonts emake html
+ fi
+}
+
+python_test() {
+ cd test || die
+
+ local t
+ for t in *.py; do
+ "${PYTHON}" "${t}" || die
+ done
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}