summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 22:01:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-28 22:01:02 +0000
commit5520c02e9458e033290a0bdaa88b245bbd4bba14 (patch)
treed9b63c6c83ca2e808e2a5e8b890dba273b395d2b /dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-5520c02e9458e033290a0bdaa88b245bbd4bba14.tar.gz
gentoo-2-5520c02e9458e033290a0bdaa88b245bbd4bba14.tar.bz2
gentoo-2-5520c02e9458e033290a0bdaa88b245bbd4bba14.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.15_rc1.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1.ebuild46
1 files changed, 32 insertions, 14 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
index 09d4dabdf6de..5102f7a15017 100644
--- a/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
@@ -1,44 +1,62 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild,v 1.1 2010/01/01 21:15:24 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild,v 1.2 2010/05/28 22:01:02 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="A fully functional X client library for Python, written in Python"
HOMEPAGE="http://python-xlib.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE="doc"
-DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- >=sys-apps/texinfo-4.8-r2 )"
+
+DEPEND="doc? (
+ virtual/latex-base
+ >=sys-apps/texinfo-4.8-r2
+ )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="Xlib"
src_compile() {
distutils_src_compile
+
if use doc; then
cd doc
- VARTEXFONTS="${T}"/fonts emake || die "make docs failed"
+ einfo "Generation of documentation"
+ VARTEXFONTS="${T}"/fonts emake || die "Generation of documentation failed"
fi
}
+src_test() {
+ cd test
+ testing() {
+ local return_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || return_status="1"
+ done
+ return "${return_status}"
+ }
+ python_execute_function testing
+}
+
src_install () {
distutils_src_install
+
if use doc; then
dohtml -r doc/html/
dodoc doc/ps/python-xlib.ps
fi
}
-
-src_test() {
- distutils_python_version
- for pytest in $(ls test/*py); do
- PYTHONPATH=. "${python}" ${pytest} || die "test failed"
- done
-}