summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-26 07:29:34 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-26 07:29:34 +0000
commit8baf1936da785eda08fff343fc129dd43e78bd49 (patch)
tree647de84eef40cf9bf6684da80aa922f0a7f6daf9 /dev-python/python-sqlparse
parentminor correction in past Changelog entry (diff)
downloadgentoo-2-8baf1936da785eda08fff343fc129dd43e78bd49.tar.gz
gentoo-2-8baf1936da785eda08fff343fc129dd43e78bd49.tar.bz2
gentoo-2-8baf1936da785eda08fff343fc129dd43e78bd49.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-sqlparse')
-rw-r--r--dev-python/python-sqlparse/ChangeLog7
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/python-sqlparse/ChangeLog b/dev-python/python-sqlparse/ChangeLog
index 2bde46b9470b..0b87d0e13ced 100644
--- a/dev-python/python-sqlparse/ChangeLog
+++ b/dev-python/python-sqlparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-sqlparse
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.36 2014/10/26 07:11:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/ChangeLog,v 1.37 2014/10/26 07:29:34 idella4 Exp $
+
+*python-sqlparse-0.1.13 (26 Oct 2014)
+
+ 26 Oct 2014; Ian Delaney <idella4@gentoo.org> +python-sqlparse-0.1.13.ebuild:
+ bump
24 Oct 2014; Anthony G. Basile <blueness@gentoo.org>
python-sqlparse-0.1.12.ebuild:
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild
new file mode 100644
index 000000000000..27c93d12bf7c
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-sqlparse/python-sqlparse-0.1.13.ebuild,v 1.1 2014/10/26 07:29:34 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="http://code.google.com/p/python-sqlparse/ https://github.com/andialbrecht/sqlparse"
+SRC_URI="https://github.com/andialbrecht/sqlparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~ppc ~ppc64 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+# Required for running tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}"/${P#python-}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}