summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-17 04:15:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-17 04:15:24 +0000
commitd5d6ef9f3bda33ff3c3428e873bd15e3d00b79aa (patch)
tree022ee91ed025571a8161eb1625e4954691d727d8 /dev-python/python-ptrace
parentBackport the requirement of python[sqlite] from newer versions, bug #525594. (diff)
downloadgentoo-2-d5d6ef9f3bda33ff3c3428e873bd15e3d00b79aa.tar.gz
gentoo-2-d5d6ef9f3bda33ff3c3428e873bd15e3d00b79aa.tar.bz2
gentoo-2-d5d6ef9f3bda33ff3c3428e873bd15e3d00b79aa.zip
bump; add IUSE doc to install doc folder's files
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog7
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index a795992906f2..ea8c67c61505 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.14 2014/08/10 21:19:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.15 2014/10/17 04:15:24 idella4 Exp $
+
+*python-ptrace-0.8 (17 Oct 2014)
+
+ 17 Oct 2014; Ian Delaney <idella4@gentoo.org> +python-ptrace-0.8.ebuild:
+ bump; add IUSE doc to install doc folder's files
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
python-ptrace-0.6.6.ebuild, python-ptrace-0.7.ebuild:
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.ebuild
new file mode 100644
index 000000000000..e9552c18aa6c
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.8.ebuild,v 1.1 2014/10/17 04:15:24 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+# Req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ echo "${EPYTHON}"
+ if python_is_python3; then
+ 2to3 -w ptrace
+ fi
+ "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ # doc folder missing key files to effect a proper doc build
+ use doc && local DOCS=( README doc/* )
+ distutils-r1_python_install_all
+}