summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 01:42:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 01:42:56 +0000
commit518ec2e96f85d49ffd50f8850d7a7aae0d06a760 (patch)
treebb30af98dad9d50f428d08a2d6ce3cea5e3b8b8a /dev-python/python-openid
parentDelete older ebuild. (diff)
downloadgentoo-2-518ec2e96f85d49ffd50f8850d7a7aae0d06a760.tar.gz
gentoo-2-518ec2e96f85d49ffd50f8850d7a7aae0d06a760.tar.bz2
gentoo-2-518ec2e96f85d49ffd50f8850d7a7aae0d06a760.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14469-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/ChangeLog6
-rw-r--r--dev-python/python-openid/python-openid-2.2.4.ebuild39
2 files changed, 26 insertions, 19 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index 535683c9fad3..372e87b3cec0 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.10 2009/09/03 22:47:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.11 2009/10/01 01:42:56 arfrever Exp $
+
+ 01 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-openid-2.2.4.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*python-openid-2.2.4 (03 Sep 2009)
diff --git a/dev-python/python-openid/python-openid-2.2.4.ebuild b/dev-python/python-openid/python-openid-2.2.4.ebuild
index 976d6cd13a19..8f535e460a02 100644
--- a/dev-python/python-openid/python-openid-2.2.4.ebuild
+++ b/dev-python/python-openid/python-openid-2.2.4.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.4.ebuild,v 1.1 2009/09/03 22:47:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.4.ebuild,v 1.2 2009/10/01 01:42:56 arfrever Exp $
-NEED_PYTHON=2.3
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -15,22 +18,29 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples mysql postgres sqlite"
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )
- || ( >=dev-lang/python-2.5 dev-python/pycrypto )
- sqlite? (
- || ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2 )
- )
+RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2 )
postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.2 )"
+ sqlite? ( || ( dev-lang/python[sqlite] >=dev-python/pysqlite-2 ) )"
DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="openid"
-src_unpack() {
- distutils_src_unpack
+src_prepare() {
+ distutils_src_prepare
# Patch to fix confusion with localhost/127.0.0.1
- epatch "${FILESDIR}"/${PN}-2.0.0-gentoo-test_fetchers.diff
+ epatch "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
+}
+
+src_test() {
+ # Remove test that requires running db server.
+ sed -e '/storetest/d' -i admin/runtests
+
+ testing() {
+ "$(PYTHON)" admin/runtests
+ }
+ python_execute_function testing
}
src_install() {
@@ -43,10 +53,3 @@ src_install() {
doins -r examples
fi
}
-
-src_test() {
- #Remove test that requires running db server
- sed -e '/storetest/d' -i admin/runtests
-
- "${python}" admin/runtests || die "tests failed"
-}