summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2014-08-02 21:16:03 +0000
committerPatrick McLean <chutzpah@gentoo.org>2014-08-02 21:16:03 +0000
commit2dbe0e52cacd2290b8863ef654fa162cc738fa4c (patch)
treec505a03997ecf57fd4554fda5b75958b95158b23 /dev-python/python-iptables
parentStable for all; Drop old. (diff)
downloadgentoo-2-2dbe0e52cacd2290b8863ef654fa162cc738fa4c.tar.gz
gentoo-2-2dbe0e52cacd2290b8863ef654fa162cc738fa4c.tar.bz2
gentoo-2-2dbe0e52cacd2290b8863ef654fa162cc738fa4c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/ChangeLog8
-rw-r--r--dev-python/python-iptables/python-iptables-0.4.0.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/python-iptables/ChangeLog b/dev-python/python-iptables/ChangeLog
index 56c47d97981c..91140a58cef2 100644
--- a/dev-python/python-iptables/ChangeLog
+++ b/dev-python/python-iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-iptables
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/ChangeLog,v 1.7 2014/04/01 17:39:39 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/ChangeLog,v 1.8 2014/08/02 21:16:03 chutzpah Exp $
+
+*python-iptables-0.4.0 (02 Aug 2014)
+
+ 02 Aug 2014; Patrick McLean <chutzpah@gentoo.org>
+ +python-iptables-0.4.0.ebuild:
+ Version bump.
*python-iptables-0.3.0_p20130331 (01 Apr 2014)
diff --git a/dev-python/python-iptables/python-iptables-0.4.0.ebuild b/dev-python/python-iptables/python-iptables-0.4.0.ebuild
new file mode 100644
index 000000000000..459c86cd228a
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iptables/python-iptables-0.4.0.ebuild,v 1.1 2014/08/02 21:16:03 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables."
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="net-firewall/iptables"
+RDEPEND="${DEPEND}"
+
+# tests manipulate live iptables rules, so disable them by default
+RESTRICT=test
+# needed for running tests
+#RESTRICT=userpriv
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.0-tests.patch"
+)
+
+python_test() {
+ ${PYTHON} test.py || die "tests fail with ${EPYTHON}"
+}