summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-11 03:02:22 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-11 03:02:22 +0000
commit9957fb4fee0df994c718b195d4b3b38bd8f4ac8a (patch)
treefcd92464e32fae54ab6cf078cb6fc5cbe4c1833d /dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild
parentupdate of python-quantumclient to 2.2.0 (diff)
downloadgentoo-2-9957fb4fee0df994c718b195d4b3b38bd8f4ac8a.tar.gz
gentoo-2-9957fb4fee0df994c718b195d4b3b38bd8f4ac8a.tar.bz2
gentoo-2-9957fb4fee0df994c718b195d4b3b38bd8f4ac8a.zip
bumping python-glanceclient to 0.8.0
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild
new file mode 100644
index 000000000000..951d698711b8
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.8.0.ebuild,v 1.1 2013/03/11 03:02:22 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+#tests restricted due to unpackaged deps
+RESTRICT="test"
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? ( dev-python/mox
+# dev-python/coverage
+# dev-python/discover #not packaged
+# =dev-python/pep8-1.3.3
+# >=dev-python/setuptools-git-0.4
+# >=dev-python/sphinx-1.1.2
+# >=dev-python/testrepository-0.0.13 #not packaged
+# >=dev-python/testtools-0.9.22 )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.1.2[${PYTHON_USEDEP}]
+ <dev-python/python-keystoneclient-1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6
+ <dev-python/prettytable-0.7
+ dev-python/pyopenssl
+ >=dev-python/warlock-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]"
+
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}