summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-13 01:38:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-13 01:38:10 +0000
commitd534734f4cd34802cb2ea0ee5ae298bcb0198b1c (patch)
tree47fcc9e9938cb6bfbb8de413f33163300f80ae50 /dev-python/python-docs/python-docs-2.2.3.ebuild
parentversion bump (diff)
downloadgentoo-2-d534734f4cd34802cb2ea0ee5ae298bcb0198b1c.tar.gz
gentoo-2-d534734f4cd34802cb2ea0ee5ae298bcb0198b1c.tar.bz2
gentoo-2-d534734f4cd34802cb2ea0ee5ae298bcb0198b1c.zip
version bump
Diffstat (limited to 'dev-python/python-docs/python-docs-2.2.3.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.2.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.2.3.ebuild b/dev-python/python-docs/python-docs-2.2.3.ebuild
new file mode 100644
index 000000000000..cbca5d05a7f5
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.2.3.ebuild,v 1.1 2003/07/13 01:38:01 liquidx Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML documentation for Python"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+HOMEPAGE="http://www.python.org/doc/2.2/"
+DEPEND=""
+RDEPEND=""
+SLOT="2.2"
+LICENSE="PSF-2.2"
+KEYWORDS="x86 ppc sparc alpha"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+
+src_install() {
+ docinto html
+ cp -R ${S}/* ${D}/usr/share/doc/${PF}/html
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html" > ${D}/etc/env.d/50python-docs
+}