summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-08-24 23:12:49 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-08-24 23:12:49 +0000
commita2c94824f055c57a864ee54beda15206767f6b29 (patch)
treeb6e8780c9b0447bdbb2e65d270af17030db9c4c2 /dev-python/python-biggles
parentMarked stable on amd64 as per bug 189977. (diff)
downloadgentoo-2-a2c94824f055c57a864ee54beda15206767f6b29.tar.gz
gentoo-2-a2c94824f055c57a864ee54beda15206767f6b29.tar.bz2
gentoo-2-a2c94824f055c57a864ee54beda15206767f6b29.zip
Check for media-libs/plotutils built with USE="X" and add X deps. Closes bug #152072 Thanks to Patrick Lauer
(Portage version: 2.1.2.11)
Diffstat (limited to 'dev-python/python-biggles')
-rw-r--r--dev-python/python-biggles/ChangeLog8
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.3.ebuild18
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild16
-rw-r--r--dev-python/python-biggles/python-biggles-1.6.4.ebuild16
4 files changed, 50 insertions, 8 deletions
diff --git a/dev-python/python-biggles/ChangeLog b/dev-python/python-biggles/ChangeLog
index a4b550b55dac..759b4eafc2a9 100644
--- a/dev-python/python-biggles/ChangeLog
+++ b/dev-python/python-biggles/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-biggles
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.9 2007/07/21 16:07:33 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/ChangeLog,v 1.10 2007/08/24 23:12:49 coldwind Exp $
+
+ 24 Aug 2007; Santiago M. Mola <coldwind@gentoo.org>
+ python-biggles-1.6.3.ebuild, python-biggles-1.6.4.ebuild,
+ python-biggles-1.6.4-r1.ebuild:
+ Check for media-libs/plotutils built with USE="X" and add X deps. Closes bug
+ #152072 Thanks to Patrick Lauer
*python-biggles-1.6.4-r1 (21 Jul 2007)
diff --git a/dev-python/python-biggles/python-biggles-1.6.3.ebuild b/dev-python/python-biggles/python-biggles-1.6.3.ebuild
index 6ab37f3abec0..c26018177544 100644
--- a/dev-python/python-biggles/python-biggles-1.6.3.ebuild
+++ b/dev-python/python-biggles/python-biggles-1.6.3.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.3.ebuild,v 1.10 2007/07/04 21:08:32 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.3.ebuild,v 1.11 2007/08/24 23:12:49 coldwind Exp $
-inherit distutils
+inherit eutils distutils
DESCRIPTION="A Python module for creating publication-quality 2D scientific plots."
SRC_URI="mirror://sourceforge/biggles/${P}.tar.gz"
HOMEPAGE="http://biggles.sourceforge.net"
DEPEND="~media-libs/plotutils-2.4.1
- dev-python/numeric"
+ dev-python/numeric
+ x11-libs/libSM
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
IUSE=""
SLOT="0"
@@ -17,3 +20,12 @@ KEYWORDS="x86"
LICENSE="GPL-2"
DOCS="examples/*"
+
+pkg_setup() {
+ if ! built_with_use media-libs/plotutils X ; then
+ eerror "${P} needs media-libs/plotutils built with"
+ eerror "USE=\"X\", please rebuild it with X enabled"
+ eerror "and emerge ${P} again."
+ die "media-libs/plotutils built without USE=\"X\""
+ fi
+}
diff --git a/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild b/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild
index 6c5aeebd11b8..e2dfbc3c9c66 100644
--- a/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild
+++ b/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild,v 1.1 2007/07/21 16:07:33 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.4-r1.ebuild,v 1.2 2007/08/24 23:12:49 coldwind Exp $
inherit distutils eutils
@@ -12,7 +12,10 @@ SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
HOMEPAGE="http://biggles.sourceforge.net/"
DEPEND="~media-libs/plotutils-2.4.1
- dev-python/numpy"
+ dev-python/numpy
+ x11-libs/libSM
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
IUSE=""
SLOT="0"
@@ -21,6 +24,15 @@ LICENSE="GPL-2"
PYTHON_MODNAME=biggles
+pkg_setup() {
+ if ! built_with_use media-libs/plotutils X ; then
+ eerror "${P} needs media-libs/plotutils built with"
+ eerror "USE=\"X\", please rebuild it with X enabled"
+ eerror "and emerge ${P} again."
+ die "media-libs/plotutils built without USE=\"X\""
+ fi
+}
+
src_unpack() {
distutils_src_unpack
diff --git a/dev-python/python-biggles/python-biggles-1.6.4.ebuild b/dev-python/python-biggles/python-biggles-1.6.4.ebuild
index 8062eaba1a52..22fdac0def7e 100644
--- a/dev-python/python-biggles/python-biggles-1.6.4.ebuild
+++ b/dev-python/python-biggles/python-biggles-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.4.ebuild,v 1.4 2007/01/08 17:20:20 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-biggles/python-biggles-1.6.4.ebuild,v 1.5 2007/08/24 23:12:49 coldwind Exp $
inherit distutils
@@ -12,13 +12,25 @@ SRC_URI="mirror://sourceforge/biggles/${MY_P}.tar.gz"
HOMEPAGE="http://biggles.sourceforge.net"
DEPEND="~media-libs/plotutils-2.4.1
- dev-python/numeric"
+ dev-python/numeric
+ x11-libs/libSM
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
IUSE=""
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
LICENSE="GPL-2"
+pkg_setup() {
+ if ! built_with_use media-libs/plotutils X ; then
+ eerror "${P} needs media-libs/plotutils built with"
+ eerror "USE=\"X\", please rebuild it with X enabled"
+ eerror "and emerge ${P} again."
+ die "media-libs/plotutils built without USE=\"X\""
+ fi
+}
+
src_install() {
distutils_src_install