summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-21 15:17:30 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-21 15:17:30 +0000
commitdcd804a8976451cd9e4443b3128c36829b105dd7 (patch)
tree926a7382f34579b65ed6d0bcc90ba3c66c07b0b3 /dev-python/pytables
parentVersion bump (diff)
downloadgentoo-2-dcd804a8976451cd9e4443b3128c36829b105dd7.tar.gz
gentoo-2-dcd804a8976451cd9e4443b3128c36829b105dd7.tar.bz2
gentoo-2-dcd804a8976451cd9e4443b3128c36829b105dd7.zip
drop py2.6 add py3.4 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog5
-rw-r--r--dev-python/pytables/pytables-3.1.1.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index fedc60ad8a7e..9bb83022868a 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pytables
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.51 2014/04/14 17:48:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.52 2014/06/21 15:17:30 idella4 Exp $
+
+ 21 Jun 2014; Ian Delaney <idella4@gentoo.org> pytables-3.1.1.ebuild:
+ drop py2.6 add py3.4 support
*pytables-3.1.1 (14 Apr 2014)
diff --git a/dev-python/pytables/pytables-3.1.1.ebuild b/dev-python/pytables/pytables-3.1.1.ebuild
index b802b449a229..8724daa17379 100644
--- a/dev-python/pytables/pytables-3.1.1.ebuild
+++ b/dev-python/pytables/pytables-3.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-3.1.1.ebuild,v 1.1 2014/04/14 17:48:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-3.1.1.ebuild,v 1.2 2014/06/21 15:17:30 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
MY_PN=tables
MY_P=${MY_PN}-${PV}
@@ -43,6 +43,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
python_test() {
cd "${BUILD_DIR}"/lib* || die
${EPYTHON} tables/tests/test_all.py || die