summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-10 15:11:30 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-10 15:11:30 +0000
commit2fdb9fae2ea37a564871bf91f479887a581d9bfd (patch)
tree3d6c185512cb6391b48fe136a86054b9dc284589 /dev-python/pysvn
parentUnmask dev-python/{shiboken,pyside,pyside-tools}. (diff)
downloadgentoo-2-2fdb9fae2ea37a564871bf91f479887a581d9bfd.tar.gz
gentoo-2-2fdb9fae2ea37a564871bf91f479887a581d9bfd.tar.bz2
gentoo-2-2fdb9fae2ea37a564871bf91f479887a581d9bfd.zip
Moved to EAPI=4 and imported changes from progress overlay including FLAGS respect patch, typo fix backport from upstream, fix test # 389241 & 387777, thanks Arfrever for the work
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog8
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch104
-rw-r--r--dev-python/pysvn/pysvn-1.7.6.ebuild36
3 files changed, 127 insertions, 21 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 8d7259ff989d..a9148662a1dc 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.24 2012/03/10 13:08:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.25 2012/03/10 15:11:30 jlec Exp $
+
+ 10 Mar 2012; Justin Lecher <jlec@gentoo.org> pysvn-1.7.6.ebuild,
+ +files/pysvn-1.7.6-respect_flags.patch:
+ Moved to EAPI=4 and imported changes from progress overlay including FLAGS
+ respect patch, typo fix backport from upstream, fix test # 389241 & 387777,
+ thanks Arfrever for the work
10 Mar 2012; Justin Lecher <jlec@gentoo.org> pysvn-1.7.5.ebuild,
pysvn-1.7.6.ebuild:
diff --git a/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch
new file mode 100644
index 000000000000..6f7f4e3cd5c3
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch
@@ -0,0 +1,104 @@
+--- Source/setup_configure.py
++++ Source/setup_configure.py
+@@ -821,8 +821,8 @@
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -864,7 +864,7 @@
+
+ rules.append( '%s : %s' % (target_filename, ' '.join( all_objects )) )
+ rules.append( '\t@echo Link %s' % (target_filename,) )
+- rules.append( '\t@%%(LDSHARED)s -o %s %%(CCCFLAGS)s %s' % (target_filename, ' '.join( all_objects )) )
++ rules.append( '\t@%%(LDSHARED)s -o %s %%(CCCFLAGS)s %s %%(LDLIBS)s' % (target_filename, ' '.join( all_objects )) )
+
+ self.makePrint( self.expand( '\n'.join( rules ) ) )
+
+@@ -939,8 +939,8 @@
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1004,12 +1004,12 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-no-long-double '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1022,7 +1022,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS)',
+ '-no-long-double',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s',
+@@ -1049,13 +1049,12 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1115,11 +1114,11 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1129,6 +1128,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1145,7 +1145,7 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g %(LDLIBS)s' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/pysvn-1.7.6.ebuild b/dev-python/pysvn/pysvn-1.7.6.ebuild
index aba3f2b557f8..c925ddaacce7 100644
--- a/dev-python/pysvn/pysvn-1.7.6.ebuild
+++ b/dev-python/pysvn/pysvn-1.7.6.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.6.ebuild,v 1.2 2012/03/10 13:08:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.6.ebuild,v 1.3 2012/03/10 15:11:30 jlec Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-inherit python toolchain-funcs
+inherit eutils python toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="http://pysvn.tigris.org/"
@@ -27,6 +27,11 @@ src_prepare() {
# Don't use internal copy of dev-python/pycxx.
rm -fr Import
+ epatch "${FILESDIR}/${P}-respect_flags.patch"
+
+ # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
+ sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
+
# Fix harmless SyntaxErrors with Python 3.
sed -e "/^DISTDIR=/d" -i Source/pysvn_common.mak
@@ -48,15 +53,7 @@ src_configure() {
--pycxx-src-dir="${EPREFIX}/usr/share/python$(python_get_version)/CXX" \
--apr-inc-dir="${EPREFIX}/usr/include/apr-1" \
--apu-inc-dir="${EPREFIX}/usr/include/apr-1" \
- --svn-root-dir="${EPREFIX}/usr" || return 1
-
- sed \
- -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
- -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
- -e "/^CCC=/s:g++:$(tc-getCXX):" \
- -e "/^CC=/s:gcc:$(tc-getCC):" \
- -e "/^LDSHARED=/s:g++:$(tc-getCXX) ${LDFLAGS}:" \
- -i Makefile || die "sed failed"
+ --svn-root-dir="${EPREFIX}/usr"
}
python_execute_function -s configuration
}
@@ -64,16 +61,15 @@ src_configure() {
src_compile() {
building() {
cd Source
- emake
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
}
python_execute_function -s building
}
src_test() {
testing() {
- cd Source
- emake test || return 1
- emake -C ../Tests || return 1
+ cd Tests
+ LC_ALL="en_US.UTF-8" emake
}
python_execute_function -s testing
}
@@ -82,19 +78,19 @@ src_install() {
installation() {
cd Source/pysvn
exeinto "$(python_get_sitedir)/pysvn"
- doexe _pysvn*$(get_modname) || die "doexe failed"
+ doexe _pysvn*$(get_modname)
insinto "$(python_get_sitedir)/pysvn"
- doins __init__.py || die "doins failed"
+ doins __init__.py
}
python_execute_function -s installation
if use doc; then
- dohtml -r Docs/ || die "dohtml failed"
+ dohtml -r Docs/
fi
if use examples; then
docinto examples
- dodoc Examples/Client/* || die "dodoc examples failed"
+ dodoc Examples/Client/*
fi
}