summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-02-05 23:35:13 +0000
committerMarien Zwart <marienz@gentoo.org>2006-02-05 23:35:13 +0000
commited415f8bc78b7980973236ec7a359186484182dd (patch)
tree1f47342d326d926205ec13b903076a70a0dc2967 /dev-python/pysqlite/pysqlite-2.0.7.ebuild
parentAdd new version with fixed patch to avoid file collision when using xmms. Bug... (diff)
downloadgentoo-2-ed415f8bc78b7980973236ec7a359186484182dd.tar.gz
gentoo-2-ed415f8bc78b7980973236ec7a359186484182dd.tar.bz2
gentoo-2-ed415f8bc78b7980973236ec7a359186484182dd.zip
Remove old ebuild. Block newer sqlite in 2.0.5 because it does not work (bug #121460). Version bump to 2.0.7 which works with newer sqlite but is in package.mask because setuptools is masked.
(Portage version: 2660-svn)
Diffstat (limited to 'dev-python/pysqlite/pysqlite-2.0.7.ebuild')
-rw-r--r--dev-python/pysqlite/pysqlite-2.0.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pysqlite/pysqlite-2.0.7.ebuild b/dev-python/pysqlite/pysqlite-2.0.7.ebuild
new file mode 100644
index 000000000000..e86fcb709cdd
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.0.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.0.7.ebuild,v 1.1 2006/02/05 23:35:13 marienz Exp $
+
+inherit distutils
+
+IUSE="doc"
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="pysqlite"
+SLOT="2"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-db/sqlite-3.1
+ >=dev-python/setuptools-0.6_alpha9"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:data_files = data_files,:data_files = [],:" ${S}/setup.py
+}
+
+src_install() {
+ ${python} setup.py install --root=${D} --no-compile \
+ --single-version-externally-managed "$@" || die
+
+ DDOCS="CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO"
+ DDOCS="${DDOCS} CONTRIBUTORS TODO"
+ DDOCS="${DDOCS} Change* MANIFEST* README*"
+
+ for doc in ${DDOCS}; do
+ [ -s "$doc" ] && dodoc $doc
+ done
+
+ # Need to do the examples explicitly since dodoc
+ # doesn't do directories properly
+ if use doc ; then
+ cp -r ${S}/doc/*.{html,txt,css} ${D}/usr/share/doc/${PF} || die
+ dodir /usr/share/doc/${PF}/code || die
+ cp -r ${S}/doc/code/* ${D}/usr/share/doc/${PF}/code || die
+ fi
+}
+
+src_test() {
+ cd build/lib*
+ PYTHONPATH=. python ../../scripts/test-pysqlite || die "test failed"
+}