summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2007-03-04 09:50:06 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2007-03-04 09:50:06 +0000
commit90e6aa0723edf70e909461c4d33d2b53b63da52e (patch)
tree0932f5ec8d9fdbdc3fd0633bdb17eacbc7e21ba4 /dev-python/pyro
parentReplaced einfo with elog in pkg_postinst. (diff)
downloadgentoo-2-90e6aa0723edf70e909461c4d33d2b53b63da52e.tar.gz
gentoo-2-90e6aa0723edf70e909461c4d33d2b53b63da52e.tar.bz2
gentoo-2-90e6aa0723edf70e909461c4d33d2b53b63da52e.zip
Replaced einfo with elog in pkg_postinst. In 3.5: added doc/examples use-flags, minor cleanup.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog7
-rw-r--r--dev-python/pyro/pyro-3.4.ebuild8
-rw-r--r--dev-python/pyro/pyro-3.5.ebuild31
3 files changed, 27 insertions, 19 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 5d8b110ab138..9f684a30503f 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyro
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.13 2007/02/21 17:05:04 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.14 2007/03/04 09:50:06 lucass Exp $
+
+ 04 Mar 2007; Lukasz Strzygowski <lucass@gentoo.org> pyro-3.4.ebuild,
+ pyro-3.5.ebuild:
+ Replaced einfo with elog in pkg_postinst. In 3.5: added doc/examples
+ use-flags, minor cleanup.
21 Feb 2007; Lukasz Strzygowski <lucass@gentoo.org> files/digest-pyro-3.4,
files/digest-pyro-3.5, Manifest:
diff --git a/dev-python/pyro/pyro-3.4.ebuild b/dev-python/pyro/pyro-3.4.ebuild
index 4b454ab72148..efa8cd00885b 100644
--- a/dev-python/pyro/pyro-3.4.ebuild
+++ b/dev-python/pyro/pyro-3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.4.ebuild,v 1.3 2005/09/18 11:46:37 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.4.ebuild,v 1.4 2007/03/04 09:50:06 lucass Exp $
inherit distutils eutils
@@ -34,6 +34,6 @@ src_install() {
}
pkg_postinst() {
- einfo "Pyro's Event Service Daemon, /usr/bin/esd has been renamed to"
- einfo " /usr/bin/pyroesd to avoid conflict with media-sound/esound."
+ elog "Pyro's Event Service Daemon, /usr/bin/esd has been renamed to"
+ elog " /usr/bin/pyroesd to avoid conflict with media-sound/esound."
}
diff --git a/dev-python/pyro/pyro-3.5.ebuild b/dev-python/pyro/pyro-3.5.ebuild
index 056a3d1db36b..e30ef81caa13 100644
--- a/dev-python/pyro/pyro-3.5.ebuild
+++ b/dev-python/pyro/pyro-3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.5.ebuild,v 1.2 2006/04/01 18:50:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.5.ebuild,v 1.3 2007/03/04 09:50:06 lucass Exp $
inherit distutils eutils
@@ -12,29 +12,32 @@ SRC_URI="mirror://sourceforge/pyro/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE=""
+IUSE="doc examples"
-DEPEND="virtual/python"
-
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-3.4-unattend.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.4-unattend.patch
}
src_install() {
distutils_src_install
- dodir /usr/share/doc/${PF}/examples
- cp -r ${S}/examples ${D}/usr/share/doc/${PF}
- dohtml -r docs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
- mv ${D}/usr/bin/esd ${D}/usr/bin/pyroesd
+ mv "${D}"/usr/bin/esd "${D}"/usr/bin/pyroesd
}
pkg_postinst() {
- einfo "Pyro's Event Service Daemon, /usr/bin/esd has been renamed to"
- einfo " /usr/bin/pyroesd to avoid conflict with media-sound/esound."
+ elog "Pyro's Event Service Daemon, /usr/bin/esd has been renamed to"
+ elog " /usr/bin/pyroesd to avoid conflict with media-sound/esound."
}