summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-10-08 18:57:40 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-10-08 18:57:40 +0000
commit8f4291217ca24e595e6d7bbb34c650383ab9a2f8 (patch)
tree9f02e41141588154be8ce6498e5e48bb1ceea316 /dev-python/pyro
parentversion bump (diff)
downloadgentoo-2-8f4291217ca24e595e6d7bbb34c650383ab9a2f8.tar.gz
gentoo-2-8f4291217ca24e595e6d7bbb34c650383ab9a2f8.tar.bz2
gentoo-2-8f4291217ca24e595e6d7bbb34c650383ab9a2f8.zip
Version bump.
NEWS ~~~~ Pyro 4.22 - support added in daemon to accept multiple serializers in incoming messages - new config item added for that: SERIALIZERS_ACCEPTED (defaults to ‘safe’ serializers) - wire protocol header changed. Not backwards compatible! New protocol version: 46. - wire protocol: header now contains serializer used for the data payload - wire protocol: header is extensible with optional ‘annotations’. One is used for the HMAC digest that used to be in all messages even when the hmac option wasn’t enabled. - refactored core.MessageFactory: new submodule Pyro4.message. If you used MessageFactory in your own code you’ll need to refactor it to use the new Pyro4.message.Message API instead. - disconnects example client code updated to reflect this API change - you can now write the protocol in URIs in lowercase if you want (“pyro:...”) (will still be converted to uppercase) - fixed poll server loop() not handling self.clients which caused crashes with a custom loopCondition - fixed some unit test hang/timeout/crash issues - improved unit tests for jython, disabled ipv6 tests for jython because of too many issues. - improved unit tests for ironpython. Pyro 4.21 - fixed denial of service vulnerabilities in socket servers - MSG_PING message type added (internal server ping mechanism) - disconnects example added that uses MSG_PING - more exception types recognised in the serializers (such as GeneratorExit) - fixed async regression when dealing with errors (properly serialize exceptionwrapper) - fixed warehouse and stockmarket tutorials to work with new serializer logic - fixed examples that didn’t yet work with new serializer logic - fixed unit tests to use unittest2 on Python 2.6 - no longer supports jython 2.5. You’ll have to upgrade to jython 2.7. - got rid of some byte/str handling cruft (because we no longer need to deal with jython 2.5) - implemented autoproxy support for serpent and json serializers. It is not possible to do this for marshal. - fixed serpent serialization problem with backslash escapes in unicode strings (requires serpent >= 1.3) (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog53
-rw-r--r--dev-python/pyro/pyro-4.22.ebuild78
2 files changed, 130 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index a01ac57da806..50bcf6b8939c 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,57 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.90 2013/10/06 19:17:10 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.91 2013/10/08 18:57:40 aidecoe Exp $
+
+*pyro-4.22 (08 Oct 2013)
+
+ 08 Oct 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> +pyro-4.22.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+
+ Pyro 4.22
+
+ - support added in daemon to accept multiple serializers in incoming messages
+ - new config item added for that: SERIALIZERS_ACCEPTED (defaults to ‘safe’
+ serializers)
+ - wire protocol header changed. Not backwards compatible! New protocol
+ version: 46.
+ - wire protocol: header now contains serializer used for the data payload
+ - wire protocol: header is extensible with optional ‘annotations’. One is
+ used for the HMAC digest that used to be in all messages even when the hmac
+ option wasn’t enabled.
+ - refactored core.MessageFactory: new submodule Pyro4.message. If you used
+ MessageFactory in your own code you’ll need to refactor it to use the new
+ Pyro4.message.Message API instead.
+ - disconnects example client code updated to reflect this API change
+ - you can now write the protocol in URIs in lowercase if you want
+ (“pyro:...”) (will still be converted to uppercase)
+ - fixed poll server loop() not handling self.clients which caused crashes
+ with a custom loopCondition
+ - fixed some unit test hang/timeout/crash issues
+ - improved unit tests for jython, disabled ipv6 tests for jython because of
+ too many issues.
+ - improved unit tests for ironpython.
+
+ Pyro 4.21
+
+ - fixed denial of service vulnerabilities in socket servers
+ - MSG_PING message type added (internal server ping mechanism)
+ - disconnects example added that uses MSG_PING
+ - more exception types recognised in the serializers (such as GeneratorExit)
+ - fixed async regression when dealing with errors (properly serialize
+ exceptionwrapper)
+ - fixed warehouse and stockmarket tutorials to work with new serializer logic
+ - fixed examples that didn’t yet work with new serializer logic
+ - fixed unit tests to use unittest2 on Python 2.6
+ - no longer supports jython 2.5. You’ll have to upgrade to jython 2.7.
+ - got rid of some byte/str handling cruft (because we no longer need to deal
+ with jython 2.5)
+ - implemented autoproxy support for serpent and json serializers. It is not
+ possible to do this for marshal.
+ - fixed serpent serialization problem with backslash escapes in unicode
+ strings (requires serpent >= 1.3)
06 Oct 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> pyro-4.20.ebuild:
Use virtual/python-unittest2. Fixes bug #483726.
diff --git a/dev-python/pyro/pyro-4.22.ebuild b/dev-python/pyro/pyro-4.22.ebuild
new file mode 100644
index 000000000000..40f7928b2959
--- /dev/null
+++ b/dev-python/pyro/pyro-4.22.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.22.ebuild,v 1.1 2013/10/08 18:57:40 aidecoe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="!dev-python/pyro:0
+ dev-python/serpent[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed \
+ -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' \
+ -i tests/run_suite.py || die
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -e "s/testBCLookup/_&/" \
+ -i tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testServerConnections/_&/" \
+ -e "s/testServerParallelism/_&/" \
+ -i tests/PyroTests/test_server.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -e "s/testGetIpVersion[46]/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${S}"/tests || die
+ ${PYTHON} run_suite.py || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}