summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-11-05 21:18:12 +0000
committerMichał Górny <mgorny@gentoo.org>2014-11-05 21:18:12 +0000
commit4f65b01f8dac88adfc09d559b0d722bd305a4eb0 (patch)
tree83b5b987eb96bb5b4f6c11d223c3c967a099eba0 /dev-python/pypy-bin
parentRevert the gdbm change. I was wrong, and _gdbm is only in PyPy 3. (diff)
downloadgentoo-2-4f65b01f8dac88adfc09d559b0d722bd305a4eb0.tar.gz
gentoo-2-4f65b01f8dac88adfc09d559b0d722bd305a4eb0.tar.bz2
gentoo-2-4f65b01f8dac88adfc09d559b0d722bd305a4eb0.zip
Revert the gdbm change. I was wrong, and _gdbm is only in PyPy 3.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/pypy-bin')
-rw-r--r--dev-python/pypy-bin/ChangeLog6
-rw-r--r--dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild4
-rw-r--r--dev-python/pypy-bin/pypy-bin-2.4.0.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pypy-bin/ChangeLog b/dev-python/pypy-bin/ChangeLog
index 7da47c435404..c9c265f63067 100644
--- a/dev-python/pypy-bin/ChangeLog
+++ b/dev-python/pypy-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pypy-bin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/ChangeLog,v 1.25 2014/11/05 18:13:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/ChangeLog,v 1.26 2014/11/05 21:18:12 mgorny Exp $
+
+ 05 Nov 2014; Michał Górny <mgorny@gentoo.org> pypy-bin-2.3.1-r2.ebuild,
+ pypy-bin-2.4.0.ebuild:
+ Revert the gdbm change. I was wrong, and _gdbm is only in PyPy 3.
05 Nov 2014; Michał Górny <mgorny@gentoo.org> pypy-bin-2.3.1-r2.ebuild,
pypy-bin-2.4.0.ebuild:
diff --git a/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild b/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild
index e26afc57537d..3165c37af4fe 100644
--- a/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild,v 1.2 2014/11/05 18:13:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.3.1-r2.ebuild,v 1.3 2014/11/05 21:18:12 mgorny Exp $
EAPI=5
@@ -165,7 +165,7 @@ src_install() {
"${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
- "${PYTHON}" -c "import _gdbm" || die "Failed to import gdbm (cffi)"
+ "${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
diff --git a/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild b/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
index c40fabcd6aeb..6c7e19734204 100644
--- a/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild,v 1.4 2014/11/05 18:13:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypy-bin/pypy-bin-2.4.0.ebuild,v 1.5 2014/11/05 21:18:12 mgorny Exp $
EAPI=5
@@ -171,7 +171,7 @@ src_install() {
"${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
- "${PYTHON}" -c "import _gdbm" || die "Failed to import gdbm (cffi)"
+ "${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"