summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-20 16:14:31 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-20 16:14:31 +0000
commit691d07f3c0eb678afaf57e8b0f8bcc43d1753d85 (patch)
tree600560aadaed3ef32ff1eb8dca9fb7f2c97a73f2 /dev-python/pyparted
parentVersion bump (diff)
downloadgentoo-2-691d07f3c0eb678afaf57e8b0f8bcc43d1753d85.tar.gz
gentoo-2-691d07f3c0eb678afaf57e8b0f8bcc43d1753d85.tar.bz2
gentoo-2-691d07f3c0eb678afaf57e8b0f8bcc43d1753d85.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog9
-rw-r--r--dev-python/pyparted/pyparted-3.10.3.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 2cecb73a99c1..592b07931909 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.90 2014/12/09 09:42:41 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.91 2015/01/20 16:14:31 jer Exp $
+
+*pyparted-3.10.3 (20 Jan 2015)
+
+ 20 Jan 2015; Jeroen Roovers <jer@gentoo.org> +pyparted-3.10.3.ebuild:
+ Version bump.
*pyparted-3.10.2 (09 Dec 2014)
diff --git a/dev-python/pyparted/pyparted-3.10.3.ebuild b/dev-python/pyparted/pyparted-3.10.3.ebuild
new file mode 100644
index 000000000000..e6eb87380c5f
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.10.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.10.3.ebuild,v 1.1 2015/01/20 16:14:31 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${P}