summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 19:51:45 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 19:51:45 +0000
commit9d5529768f8f738ac139257ba67147a32e363b1f (patch)
treedeff49bab55ba0b04cae81a886b3d960c293741b /dev-python/pyopencl
parentalpha/arm/ia64/m68k/s390/sh/sparc/x86 stable wrt #401089 (diff)
downloadgentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.tar.gz
gentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.tar.bz2
gentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.zip
Prepare for PYTHON_ABI-versioned Boost Python libraries in Boost 1.48. Delete old version. Patch by Arfrever.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/ChangeLog9
-rw-r--r--dev-python/pyopencl/pyopencl-0.92.ebuild53
-rw-r--r--dev-python/pyopencl/pyopencl-2011.2-r1.ebuild64
-rw-r--r--dev-python/pyopencl/pyopencl-2011.2.ebuild9
-rw-r--r--dev-python/pyopencl/pyopencl-9999.ebuild43
5 files changed, 103 insertions, 75 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index 264c459cb0c3..68f9e8f9db1f 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyopencl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.10 2012/01/08 22:20:24 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.11 2012/01/28 19:51:45 floppym Exp $
+
+*pyopencl-2011.2-r1 (28 Jan 2012)
+
+ 28 Jan 2012; Mike Gilbert <floppym@gentoo.org> +pyopencl-2011.2-r1.ebuild,
+ -pyopencl-0.92.ebuild, pyopencl-2011.2.ebuild, pyopencl-9999.ebuild:
+ Prepare for PYTHON_ABI-versioned Boost Python libraries in Boost 1.48. Delete
+ old version. Patch by Arfrever.
*pyopencl-2011.2 (08 Jan 2012)
diff --git a/dev-python/pyopencl/pyopencl-0.92.ebuild b/dev-python/pyopencl/pyopencl-0.92.ebuild
deleted file mode 100644
index 5325ae22eeb2..000000000000
--- a/dev-python/pyopencl/pyopencl-0.92.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-0.92.ebuild,v 1.5 2011/12/21 18:35:11 vapier Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-python/numpy-1.0.4
- dev-python/pytools
- virtual/opencl"
-DEPEND="${RDEPEND}
- dev-libs/boost[python]"
-
-src_configure()
-{
- if use opengl; then
- myconf="${myconf} --cl-enable-gl"
- fi
-
- "$(PYTHON -f)" ./configure.py --boost-python-libname=boost_python-mt \
- --boost-compiler=gcc \
- ${myconf}
-}
-
-src_install()
-{
- distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}
diff --git a/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild b/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
new file mode 100644
index 000000000000..b49144ddb5f1
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild,v 1.1 2012/01/28 19:51:45 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python]
+ dev-python/numpy
+ dev-python/pytools
+ virtual/opencl"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_configure()
+{
+ configuration() {
+ local myconf=()
+
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "$(PYTHON)" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install()
+{
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}
diff --git a/dev-python/pyopencl/pyopencl-2011.2.ebuild b/dev-python/pyopencl/pyopencl-2011.2.ebuild
index 975a7d2779b6..85dbd65c6743 100644
--- a/dev-python/pyopencl/pyopencl-2011.2.ebuild
+++ b/dev-python/pyopencl/pyopencl-2011.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2.ebuild,v 1.1 2012/01/08 22:20:24 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2.ebuild,v 1.2 2012/01/28 19:51:45 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
inherit distutils
@@ -18,12 +18,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples opengl"
-RDEPEND="dev-libs/boost[python]
+RDEPEND="<dev-libs/boost-1.48[python]
>=dev-python/numpy-1.0.4
dev-python/pytools
virtual/opencl"
-DEPEND="${RDEPEND}
- dev-libs/boost[python]"
+DEPEND="${RDEPEND}"
src_configure()
{
diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
index bdffcc649709..1103472f75d2 100644
--- a/dev-python/pyopencl/pyopencl-9999.ebuild
+++ b/dev-python/pyopencl/pyopencl-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-9999.ebuild,v 1.7 2011/12/21 18:35:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-9999.ebuild,v 1.8 2012/01/28 19:51:45 floppym Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
inherit distutils git-2
EGIT_REPO_URI="http://git.tiker.net/trees/pyopencl.git"
DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
SRC_URI=""
LICENSE="GPL-2"
@@ -20,29 +20,40 @@ SLOT="0"
KEYWORDS=""
IUSE="examples opengl"
-RDEPEND=">=dev-python/numpy-1.0.4
+RDEPEND=">=dev-libs/boost-1.48[python]
+ dev-python/numpy
=dev-python/pytools-9999
virtual/opencl"
-DEPEND="${RDEPEND}
- dev-libs/boost[python]"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
src_configure()
{
- if use opengl; then
- myconf="${myconf} --cl-enable-gl"
- fi
+ configuration() {
+ local myconf=()
- "$(PYTHON -f)" ./configure.py --boost-python-libname=boost_python-mt \
- --boost-thread-libname=boost_thread-mt --boost-compiler=gcc \
- ${myconf}
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "$(PYTHON)" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
}
src_install()
{
distutils_src_install
- insinto /usr/share/doc/${PF}
+
if use examples; then
- doins -r examples || die
+ insinto /usr/share/doc/${PF}
+ doins -r examples
fi
}