summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-04 11:07:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-04 11:07:27 +0000
commit0564d2412876a13d457c651134511b5c050dbc14 (patch)
treedf5026fe61bc9350daff0ec2c3caae848a927db1 /dev-python/pygsl
parentfix remi's mask, I wasn't clear enough on the phone that it was gmime needing... (diff)
downloadgentoo-2-0564d2412876a13d457c651134511b5c050dbc14.tar.gz
gentoo-2-0564d2412876a13d457c651134511b5c050dbc14.tar.bz2
gentoo-2-0564d2412876a13d457c651134511b5c050dbc14.zip
Version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/ChangeLog7
-rw-r--r--dev-python/pygsl/pygsl-0.9.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/pygsl/ChangeLog b/dev-python/pygsl/ChangeLog
index a1110838343b..68d0599ffa0f 100644
--- a/dev-python/pygsl/ChangeLog
+++ b/dev-python/pygsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygsl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.6 2008/06/05 14:20:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.7 2008/10/04 11:07:27 bicatali Exp $
+
+*pygsl-0.9.3 (04 Oct 2008)
+
+ 04 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> +pygsl-0.9.3.ebuild:
+ Version bump
05 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> pygsl-0.9.2.ebuild:
Added gsl dependency
diff --git a/dev-python/pygsl/pygsl-0.9.3.ebuild b/dev-python/pygsl/pygsl-0.9.3.ebuild
new file mode 100644
index 000000000000..e365c4ce2b4d
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.3.ebuild,v 1.1 2008/10/04 11:07:27 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND=">=sci-libs/gsl-1.8
+ dev-python/numpy"
+
+src_test() {
+ cd "${S}/tests"
+ PYTHONPATH=$(ls -d ../build/lib*) "${python}" run_test.py || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "install examples failed"
+ fi
+}