summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-14 10:03:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-14 10:03:08 +0000
commit0ffbffb6a582e789c0c0697a5044a870ca75f70b (patch)
tree103125431679369a12d22e0e64741f57807bc965 /dev-python/pygobject
parentKeyworded ~x86-fbsd. (diff)
downloadgentoo-2-0ffbffb6a582e789c0c0697a5044a870ca75f70b.tar.gz
gentoo-2-0ffbffb6a582e789c0c0697a5044a870ca75f70b.tar.bz2
gentoo-2-0ffbffb6a582e789c0c0697a5044a870ca75f70b.zip
add virtualx eclass to allow test suite to run properly
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog6
-rw-r--r--dev-python/pygobject/pygobject-2.14.2.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 7c2a47a8298b..1351ea6682fa 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.41 2008/07/04 23:04:08 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.42 2008/07/14 10:03:08 eva Exp $
+
+ 14 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ pygobject-2.14.2.ebuild:
+ add virtualx eclass to allow test suite to run properly
04 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+files/pygobject-2.14.2-libffi.patch, pygobject-2.14.2.ebuild:
diff --git a/dev-python/pygobject/pygobject-2.14.2.ebuild b/dev-python/pygobject/pygobject-2.14.2.ebuild
index 1d85bb6bf46f..31ec684c84e3 100644
--- a/dev-python/pygobject/pygobject-2.14.2.ebuild
+++ b/dev-python/pygobject/pygobject-2.14.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.3 2008/07/04 23:04:08 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.4 2008/07/14 10:03:08 eva Exp $
-inherit gnome2 python autotools
+inherit gnome2 python autotools virtualx
DESCRIPTION="GLib's GObject library bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -50,6 +50,10 @@ src_unpack() {
ln -s $(type -P true) py-compile
}
+src_test() {
+ Xemake check || die "tests failed"
+}
+
src_install() {
gnome2_src_install