summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-07-07 07:28:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-07-07 07:28:43 +0000
commit38af335e7e5a5b4a0c1dad0b6994a53c70ca3cf7 (patch)
tree41a13ea1194f5d69232cebbd26f4f07485660547 /dev-python/pygame
parentRemove unneeded files. Requested by Arfrever (diff)
downloadgentoo-2-38af335e7e5a5b4a0c1dad0b6994a53c70ca3cf7.tar.gz
gentoo-2-38af335e7e5a5b4a0c1dad0b6994a53c70ca3cf7.tar.bz2
gentoo-2-38af335e7e5a5b4a0c1dad0b6994a53c70ca3cf7.zip
Remove unneeded files. Requested by Arfrever
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog6
-rw-r--r--dev-python/pygame/files/config.patch26
-rw-r--r--dev-python/pygame/files/pygame-1.9.1-linux-headers-2.6.38.patch63
3 files changed, 5 insertions, 90 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 8e162b0b745d..d14fee722df4 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygame
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.79 2011/07/01 21:28:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.80 2011/07/07 07:28:43 hwoarang Exp $
+
+ 07 Jul 2011; Markos Chandras <hwoarang@gentoo.org>
+ -files/pygame-1.9.1-linux-headers-2.6.38.patch, -files/config.patch:
+ Remove unneeded files. Requested by Arfrever
01 Jul 2011; Markos Chandras <hwoarang@gentoo.org> -pygame-1.9.1.ebuild,
-pygame-1.9.1-r1.ebuild:
diff --git a/dev-python/pygame/files/config.patch b/dev-python/pygame/files/config.patch
deleted file mode 100644
index b3dab162ce0e..000000000000
--- a/dev-python/pygame/files/config.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: config_unix.py
-===================================================================
---- config_unix.py (revision 2567)
-+++ config_unix.py (working copy)
-@@ -174,7 +174,7 @@
-
- for d in DEPS[1:]:
- if not d.found:
-- if not confirm("""
-+ if "-auto" not in sys.argv and not confirm("""
- Warning, some of the pygame dependencies were not found. Pygame can still
- compile and install, but games that depend on those missing dependencies
- will not run. Would you like to continue the configuration?"""):
-Index: config_msys.py
-===================================================================
---- config_msys.py (revision 2567)
-+++ config_msys.py (working copy)
-@@ -283,7 +283,7 @@
-
- for d in DEPS[1:]:
- if not d.found:
-- if not confirm("""
-+ if "-auto" not in sys.argv and not confirm("""
- Warning, some of the pygame dependencies were not found. Pygame can still
- compile and install, but games that depend on those missing dependencies
- will not run. Would you like to continue the configuration?"""):
diff --git a/dev-python/pygame/files/pygame-1.9.1-linux-headers-2.6.38.patch b/dev-python/pygame/files/pygame-1.9.1-linux-headers-2.6.38.patch
deleted file mode 100644
index f300c6efe157..000000000000
--- a/dev-python/pygame/files/pygame-1.9.1-linux-headers-2.6.38.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- Setup.in
-+++ Setup.in
-@@ -34,7 +34,7 @@
- _numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
- movie src/movie.c $(SDL) $(SMPEG) $(DEBUG)
- scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
--_camera src/_camera.c src/camera_v4l2.c src/camera_v4l.c $(SDL) $(DEBUG)
-+_camera src/_camera.c src/camera_v4l2.c $(SDL) $(DEBUG)
- pypm src/pypm.c $(SDL) $(PORTMIDI) $(PORTTIME) $(DEBUG)
-
- GFX = src/SDL_gfx/SDL_gfxPrimitives.c
---- src/_camera.c
-+++ src/_camera.c
-@@ -160,20 +160,8 @@
- {
- #if defined(__unix__)
- if (v4l2_open_device(self) == 0) {
-- if (v4l_open_device(self) == 0) {
-- v4l2_close_device(self);
-- return NULL;
-- } else {
-- self->camera_type = CAM_V4L;
-- if (v4l_init_device(self) == 0) {
-- v4l2_close_device(self);
-- return NULL;
-- }
-- if (v4l_start_capturing(self) == 0) {
-- v4l2_close_device(self);
-- return NULL;
-- }
-- }
-+ v4l2_close_device(self);
-+ return NULL;
- } else {
- self->camera_type = CAM_V4L2;
- if (v4l2_init_device(self) == 0) {
---- src/camera.h
-+++ src/camera.h
-@@ -39,7 +39,6 @@
-
- #include <asm/types.h> /* for videodev2.h */
-
-- #include <linux/videodev.h>
- #include <linux/videodev2.h>
- #endif
-
-@@ -51,7 +50,6 @@
- #define RGB_OUT 1
- #define YUV_OUT 2
- #define HSV_OUT 4
--#define CAM_V4L 1
- #define CAM_V4L2 2
-
- struct buffer
-@@ -111,8 +109,4 @@
- int v4l2_close_device (PyCameraObject* self);
- int v4l2_open_device (PyCameraObject* self);
-
--/* internal functions specific to v4l */
--int v4l_open_device (PyCameraObject* self);
--int v4l_init_device(PyCameraObject* self);
--int v4l_start_capturing(PyCameraObject* self);
- #endif