summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-15 04:29:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-15 04:29:20 +0000
commit68dc33889860ed27d6660fdafff1ab19373a9c7c (patch)
tree4e40dd11a4ff64fc365eb9ec9d1865ad98b1ee39 /dev-python/pyconstruct
parentRemove old (diff)
downloadgentoo-2-68dc33889860ed27d6660fdafff1ab19373a9c7c.tar.gz
gentoo-2-68dc33889860ed27d6660fdafff1ab19373a9c7c.tar.bz2
gentoo-2-68dc33889860ed27d6660fdafff1ab19373a9c7c.zip
bump; drop py2.6 add py3 pypy support, rm old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog11
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.0.0.ebuild40
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.04.ebuild54
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.06.ebuild48
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.5.0.ebuild48
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.5.2.ebuild (renamed from dev-python/pyconstruct/pyconstruct-2.5.0-r1.ebuild)24
6 files changed, 16 insertions, 209 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index cfc30a4433fb..b696678212fe 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyconstruct
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.8 2013/05/22 07:28:51 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.9 2014/05/15 04:29:20 idella4 Exp $
+
+*pyconstruct-2.5.2 (15 May 2014)
+
+ 15 May 2014; Ian Delaney <idella4@gentoo.org> +pyconstruct-2.5.2.ebuild,
+ -pyconstruct-2.0.0.ebuild, -pyconstruct-2.04.ebuild, -pyconstruct-2.06.ebuild,
+ -pyconstruct-2.5.0-r1.ebuild, -pyconstruct-2.5.0.ebuild:
+ bump; drop py2.6 add py3 pypy support, rm old
*pyconstruct-2.5.1 (22 May 2013)
diff --git a/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
deleted file mode 100644
index ced4cf34ea74..000000000000
--- a/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild,v 1.2 2010/06/08 19:04:28 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit python
-
-DESCRIPTION="Library for constructing (parsing and building) of binary and textual data structures"
-HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
-SRC_URI="mirror://sourceforge/pyconstruct/construct-2.00-distro.zip"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S="${WORKDIR}/construct"
-
-src_install() {
- installation() {
- insinto $(python_get_sitedir)/construct
- doins -r *
- }
- python_execute_function installation
-}
-
-pkg_postinst() {
- python_mod_optimize construct
-}
-
-pkg_postrm() {
- python_mod_cleanup construct
-}
diff --git a/dev-python/pyconstruct/pyconstruct-2.04.ebuild b/dev-python/pyconstruct/pyconstruct-2.04.ebuild
deleted file mode 100644
index 4ca279e05b8b..000000000000
--- a/dev-python/pyconstruct/pyconstruct-2.04.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.04.ebuild,v 1.2 2011/09/16 15:09:42 mr_bones_ Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils
-
-MY_PN="construct"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A powerful declarative parser for binary data"
-HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="app-arch/unzip
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize construct
-}
-
-pkg_postrm() {
- python_mod_cleanup construct
-}
diff --git a/dev-python/pyconstruct/pyconstruct-2.06.ebuild b/dev-python/pyconstruct/pyconstruct-2.06.ebuild
deleted file mode 100644
index 7c8977eca70d..000000000000
--- a/dev-python/pyconstruct/pyconstruct-2.06.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.2 2012/01/06 21:28:06 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils
-
-MY_PN="construct"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A powerful declarative parser for binary data"
-HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="construct"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
deleted file mode 100644
index b0b26186cba5..000000000000
--- a/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild,v 1.1 2013/01/22 07:15:08 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils
-
-MY_PN="construct"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A powerful declarative parser for binary data"
-HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="construct"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/pyconstruct/pyconstruct-2.5.0-r1.ebuild b/dev-python/pyconstruct/pyconstruct-2.5.2.ebuild
index 72819f591265..8df199102d79 100644
--- a/dev-python/pyconstruct/pyconstruct-2.5.0-r1.ebuild
+++ b/dev-python/pyconstruct/pyconstruct-2.5.2.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.0-r1.ebuild,v 1.1 2013/01/24 15:31:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.2.ebuild,v 1.1 2014/05/15 04:29:20 idella4 Exp $
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-inherit distutils eutils
+inherit distutils-r1
MY_PN="construct"
MY_P="${MY_PN}-${PV}"
@@ -21,15 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools
- dev-python/six"
-RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="construct"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}"/${P}-fixpy3.patch
-}