summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-27 10:53:30 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-27 10:53:30 +0000
commitdd9be2140dff73c1d893e81fb41e2d5154b41d23 (patch)
tree56e263699d4cd5e9a57d54c7baf0c7db87493346 /dev-python/pycadf
parentFix installing to wrong libdir on amd64. Support multilib deps. (diff)
downloadgentoo-2-dd9be2140dff73c1d893e81fb41e2d5154b41d23.tar.gz
gentoo-2-dd9be2140dff73c1d893e81fb41e2d5154b41d23.tar.bz2
gentoo-2-dd9be2140dff73c1d893e81fb41e2d5154b41d23.zip
sec. patch wrt Bug #515050, add IUSE, doc build, fix test phase, rm vuln. version
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pycadf')
-rw-r--r--dev-python/pycadf/ChangeLog9
-rw-r--r--dev-python/pycadf/files/CVE-2014-4615.patch29
-rw-r--r--dev-python/pycadf/pycadf-0.5-r1.ebuild (renamed from dev-python/pycadf/pycadf-0.5.ebuild)28
3 files changed, 60 insertions, 6 deletions
diff --git a/dev-python/pycadf/ChangeLog b/dev-python/pycadf/ChangeLog
index a790a334024a..637618ad2323 100644
--- a/dev-python/pycadf/ChangeLog
+++ b/dev-python/pycadf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycadf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/ChangeLog,v 1.1 2014/04/21 00:13:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/ChangeLog,v 1.2 2014/06/27 10:53:30 idella4 Exp $
+
+*pycadf-0.5-r1 (27 Jun 2014)
+
+ 27 Jun 2014; Ian Delaney <idella4@gentoo.org> +files/CVE-2014-4615.patch,
+ +pycadf-0.5-r1.ebuild, -pycadf-0.5.ebuild:
+ sec. patch wrt Bug #515050, add IUSE, doc build, fix test phase, rm vuln.
+ version
*pycadf-0.5 (21 Apr 2014)
diff --git a/dev-python/pycadf/files/CVE-2014-4615.patch b/dev-python/pycadf/files/CVE-2014-4615.patch
new file mode 100644
index 000000000000..54596a5c2cb3
--- /dev/null
+++ b/dev-python/pycadf/files/CVE-2014-4615.patch
@@ -0,0 +1,29 @@
+https://review.openstack.org/#/c/94878/
+Owner gordon chung
+Project openstack/pycadf
+Branch master
+Topic bug1321080
+Uploaded May 22, 2014 10:12 PM
+Updated May 23, 2014 3:34 AM
+Status Merged
+
+Commit Message: remove token from notifier middleware
+
+notifier middleware is capturing token and sending it to MQ. this
+is not advisable so we should filter it out.
+
+Change-Id: I11d9f2f23fc3b60c945c33d4d02bd7640d88a083
+Closes-Bug: #1321080
+diff --git a/pycadf/middleware/notifier.py b/pycadf/middleware/notifier.py
+index fc921f8..621c8b4 100644
+--- a/pycadf/middleware/notifier.py
++++ b/pycadf/middleware/notifier.py
+@@ -88,7 +88,7 @@
+ include them.
+ """
+ return dict((k, v) for k, v in six.iteritems(environ)
+- if k.isupper())
++ if k.isupper() and k != 'HTTP_X_AUTH_TOKEN')
+
+ @log_and_ignore_error
+ def process_request(self, request):
diff --git a/dev-python/pycadf/pycadf-0.5.ebuild b/dev-python/pycadf/pycadf-0.5-r1.ebuild
index 7eb5ac49e04e..f7514ca521ab 100644
--- a/dev-python/pycadf/pycadf-0.5.ebuild
+++ b/dev-python/pycadf/pycadf-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/pycadf-0.5.ebuild,v 1.1 2014/04/21 00:13:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/pycadf-0.5-r1.ebuild,v 1.1 2014/06/27 10:53:30 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="doc test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.6[${PYTHON_USEDEP}]
@@ -33,7 +33,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )"
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )
+ doc? ( dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}] )"
+
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
@@ -44,8 +47,23 @@ RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
>=dev-python/six-1.5.2[${PYTHON_USEDEP}]
>=dev-python/webob-1.2.3[${PYTHON_USEDEP}]"
-# This time half the doc files are missing; Do you want them?
+PATCHES=( "${FILESDIR}"/CVE-2014-4615.patch )
+
+python_prepare_all() {
+ # ? typo error in conf.py
+ sed -e s':oslosphinx:oslo.sphinx:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
+ nosetests ${PN}/tests || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
}