summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 17:25:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-21 17:25:01 +0000
commit1612f44cacbd3652dbd260b79b308cce6fc7fa7f (patch)
treeb28abd3b62d2db984ca975164c09b8adf7088ed6 /dev-python/py
parentUpdated patch for arm, bug 302357. (diff)
downloadgentoo-2-1612f44cacbd3652dbd260b79b308cce6fc7fa7f.tar.gz
gentoo-2-1612f44cacbd3652dbd260b79b308cce6fc7fa7f.tar.bz2
gentoo-2-1612f44cacbd3652dbd260b79b308cce6fc7fa7f.zip
Version bump.
(Portage version: 15417-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/ChangeLog8
-rw-r--r--dev-python/py/py-1.2.1.ebuild26
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index e47d290ae264..fe5f93a74b47 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/py
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.29 2010/01/18 17:23:52 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.30 2010/02/21 17:25:01 arfrever Exp $
+
+*py-1.2.1 (21 Feb 2010)
+
+ 21 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +py-1.2.1.ebuild:
+ Version bump.
*py-1.2.0 (18 Jan 2010)
diff --git a/dev-python/py/py-1.2.1.ebuild b/dev-python/py/py-1.2.1.ebuild
new file mode 100644
index 000000000000..afafa8d563ff
--- /dev/null
+++ b/dev-python/py/py-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.2.1.ebuild,v 1.1 2010/02/21 17:25:01 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A library aiming to support agile and test-driven python development on various levels."
+SRC_URI="http://pypi.python.org/packages/source/p/${PN}/${P}.tar.gz"
+HOMEPAGE="http://codespeak.net/py/ http://pypi.python.org/pypi/py"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6.2"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ python_generate_wrapper_scripts -E -f -q "${D%/}${EPREFIX}/usr/bin/py.test"
+}