summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-11-06 01:32:06 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-11-06 01:32:06 +0000
commit733090e587154e12f3d27d4894d8a4a6f9546a64 (patch)
tree3dac0f5d9c3b3f01d65eaef835882cb9cbbf927b /dev-python/psycopg/psycopg-2.0_beta5.ebuild
parentFix typo in ChangeLog. (diff)
downloadgentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.tar.gz
gentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.tar.bz2
gentoo-2-733090e587154e12f3d27d4894d8a4a6f9546a64.zip
version bump stable version, and introduce development version that is hard masked
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-python/psycopg/psycopg-2.0_beta5.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.0_beta5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/psycopg/psycopg-2.0_beta5.ebuild b/dev-python/psycopg/psycopg-2.0_beta5.ebuild
new file mode 100644
index 000000000000..aced9cc96b52
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.0_beta5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.0_beta5.ebuild,v 1.1 2005/11/06 01:32:06 liquidx Exp $
+
+inherit distutils
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="PostgreSQL database adapter for the Python."
+SRC_URI="http://initd.org/pub/software/psycopg/${PN}2-${MY_PV}.tar.gz"
+HOMEPAGE="http://initd.org/projects/psycopg2"
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-db/postgresql-7.1.3"
+
+SLOT="2"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+S=${WORKDIR}/${PN}2-${MY_PV}
+
+DOCS="AUTHORS ChangeLog COPYING CREDITS INSTALL README NEWS docs/*"
+
+src_install () {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*
+}