summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-27 14:30:04 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-27 14:30:04 +0000
commit61e814cab5cd473fab002a7a485b37d722de77bf (patch)
tree86dbcbde04b3be0cae70cb8efcb641383285d56c /dev-python/polygon
parentUpdated EAPI to 5, fixed dependencies, ensured gx86-multilib support (diff)
downloadgentoo-2-61e814cab5cd473fab002a7a485b37d722de77bf.tar.gz
gentoo-2-61e814cab5cd473fab002a7a485b37d722de77bf.tar.bz2
gentoo-2-61e814cab5cd473fab002a7a485b37d722de77bf.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/ChangeLog11
-rw-r--r--dev-python/polygon/polygon-2.0.6.ebuild29
-rw-r--r--dev-python/polygon/polygon-3.0.6.ebuild29
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/polygon/ChangeLog b/dev-python/polygon/ChangeLog
index fa5c48e55527..32b9c76b18da 100644
--- a/dev-python/polygon/ChangeLog
+++ b/dev-python/polygon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/polygon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/ChangeLog,v 1.10 2012/11/11 13:35:09 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/ChangeLog,v 1.11 2014/06/27 14:30:04 jer Exp $
+
+*polygon-3.0.6 (27 Jun 2014)
+*polygon-2.0.6 (27 Jun 2014)
+
+ 27 Jun 2014; Jeroen Roovers <jer@gentoo.org> +polygon-2.0.6.ebuild,
+ +polygon-3.0.6.ebuild:
+ Version bump.
11 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polygon-2.0.4.ebuild:
Rapid stabilization to heal tree, bug #442318
diff --git a/dev-python/polygon/polygon-2.0.6.ebuild b/dev-python/polygon/polygon-2.0.6.ebuild
new file mode 100644
index 000000000000..f2623987d467
--- /dev/null
+++ b/dev-python/polygon/polygon-2.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-2.0.6.ebuild,v 1.1 2014/06/27 14:30:04 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="mirror://bitbucket/jraedler/${PN}2/downloads/Polygon2-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon2-${PV}
+
+DOCS=( HISTORY doc/Polygon.txt )
+
+src_test() {
+ python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" ${EPYTHON} test/Test.py || die
+ }
+ python_foreach_impl python_test
+}
diff --git a/dev-python/polygon/polygon-3.0.6.ebuild b/dev-python/polygon/polygon-3.0.6.ebuild
new file mode 100644
index 000000000000..902d5c725157
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-3.0.6.ebuild,v 1.1 2014/06/27 14:30:04 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_{2,3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon"
+SRC_URI="mirror://bitbucket/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon3-${PV}
+
+DOCS=( HISTORY doc/Polygon.txt )
+
+src_test() {
+ python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" ${EPYTHON} test/Test.py || die
+ }
+ python_foreach_impl python_test
+}