summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-09 03:41:48 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-09 03:41:48 +0000
commit066aa9121cbe7fba06546c25256c29a0f2832922 (patch)
tree82a90a89161a05d40e87d1dcca6d8c8132d7dc93 /dev-python/polib/polib-1.0.4.ebuild
parentbump; drop py2.6 py3.2 pypy2_0 add py3.4 support, update test phase (diff)
downloadgentoo-2-066aa9121cbe7fba06546c25256c29a0f2832922.tar.gz
gentoo-2-066aa9121cbe7fba06546c25256c29a0f2832922.tar.bz2
gentoo-2-066aa9121cbe7fba06546c25256c29a0f2832922.zip
New package, required for gnome-extra/nemo; thanks to pavel sanda for submitted ebuild (bug #456994).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-python/polib/polib-1.0.4.ebuild')
-rw-r--r--dev-python/polib/polib-1.0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.0.4.ebuild b/dev-python/polib/polib-1.0.4.ebuild
new file mode 100644
index 000000000000..4cc459089b30
--- /dev/null
+++ b/dev-python/polib/polib-1.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polib/polib-1.0.4.ebuild,v 1.1 2014/05/09 03:41:48 tetromino Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="https://bitbucket.org/izi/polib/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ emake html
+ fi
+}
+
+python_test() {
+ python tests/tests.py || die
+}
+
+python_install_all() {
+ local DOCS="CHANGELOG README.rst"
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}