summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-06 04:41:10 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-06 04:41:10 +0000
commit14aba44ad5c8de8e563508d5341b3cbf494f2f7c (patch)
treeb36a2d7f96aa0d9fca7995386c066677097af053 /dev-python/pmw
parentNew version 0.16 (diff)
downloadgentoo-2-14aba44ad5c8de8e563508d5341b3cbf494f2f7c.tar.gz
gentoo-2-14aba44ad5c8de8e563508d5341b3cbf494f2f7c.tar.bz2
gentoo-2-14aba44ad5c8de8e563508d5341b3cbf494f2f7c.zip
Added PYTHON_MODNAME to pmw-1.2. Added pmw-1.3.2.ebuild. Fixes bug #233638. Thanks to Necoro <gentoo@necoro.eu>
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/pmw')
-rw-r--r--dev-python/pmw/ChangeLog11
-rw-r--r--dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch13
-rw-r--r--dev-python/pmw/pmw-1.2.ebuild18
-rw-r--r--dev-python/pmw/pmw-1.3.2.ebuild56
4 files changed, 89 insertions, 9 deletions
diff --git a/dev-python/pmw/ChangeLog b/dev-python/pmw/ChangeLog
index e7c62633a1ca..21ad07f92ebf 100644
--- a/dev-python/pmw/ChangeLog
+++ b/dev-python/pmw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pmw
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.22 2007/01/06 22:53:15 dev-zero Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.23 2008/08/06 04:41:09 neurogeek Exp $
+
+*pmw-1.3.2 (06 Aug 2008)
+
+ 06 Aug 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +files/pmw-1.3.2-install-no-docs.patch, pmw-1.2.ebuild, +pmw-1.3.2.ebuild:
+ Added PYTHON_MODNAME to pmw-1.2. Added pmw-1.3.2.ebuild. Fixes bug
+ #233638. Thanks to Necoro <gentoo@necoro.eu>
06 Jan 2007; Tiziano Müller <dev-zero@gentoo.org> -pmw-0.8.5.ebuild,
-pmw-1.1.ebuild:
diff --git a/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch b/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch
new file mode 100644
index 000000000000..325dc4e2998c
--- /dev/null
+++ b/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch
@@ -0,0 +1,13 @@
+diff -uNr Pmw.1.3.2.orig/src/setup.py Pmw.1.3.2/src/setup.py
+--- Pmw.1.3.2.orig/src/setup.py 2008-08-02 15:40:19.000000000 -0430
++++ Pmw.1.3.2/src/setup.py 2008-08-02 15:40:36.000000000 -0430
+@@ -16,9 +16,7 @@
+ 'Pmw.Pmw_1_3.lib',],
+
+ package_data={'Pmw': ['Pmw_1_3/lib/Pmw.def',
+- 'Pmw_1_3/doc/*',
+ 'Pmw_1_3/contrib/*',
+- 'Pmw_1_3/demos/*',
+ 'Pmw_1_3/tests/*',
+ 'Pmw_1_3/bin/*',
+ ]
diff --git a/dev-python/pmw/pmw-1.2.ebuild b/dev-python/pmw/pmw-1.2.ebuild
index a7fff64548d8..0012cf1f4d2f 100644
--- a/dev-python/pmw/pmw-1.2.ebuild
+++ b/dev-python/pmw/pmw-1.2.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.2.ebuild,v 1.14 2006/09/27 17:23:17 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.2.ebuild,v 1.15 2008/08/06 04:41:09 neurogeek Exp $
-inherit distutils python
+PYTHON_MODNAME='Pmw'
+inherit distutils
+
+MY_P="${PYTHON_MODNAME}.${PV}"
DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
HOMEPAGE="http://pmw.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
LICENSE="MIT"
IUSE=""
-DEPEND=">=dev-lang/python-2.1"
-S="${WORKDIR}/Pmw"
+DEPEND="virtual/python"
+S="${WORKDIR}/${PYTHON_MODNAME}"
pkg_setup() {
# check for Tkinter support in python
@@ -28,7 +31,7 @@ src_compile() {
src_install() {
python_version
- local pmwdir="/usr/lib/python${PYVER}/site-packages/Pmw"
+ local pmwdir="$(python_get_sitedir)/${PYTHON_MODNAME}"
local dir
for dir in `find . -type d` ; do
@@ -49,3 +52,4 @@ src_install() {
local docdir=`find . -type d -name doc`
dohtml -a html,gif,py "${docdir}"/*
}
+
diff --git a/dev-python/pmw/pmw-1.3.2.ebuild b/dev-python/pmw/pmw-1.3.2.ebuild
new file mode 100644
index 000000000000..a2db897e430a
--- /dev/null
+++ b/dev-python/pmw/pmw-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.3.2.ebuild,v 1.1 2008/08/06 04:41:09 neurogeek Exp $
+
+PYTHON_MODNAME="Pmw"
+
+inherit distutils
+
+MY_P="Pmw.${PV}"
+
+DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+HOMEPAGE="http://pmw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="BSD"
+IUSE="doc examples"
+
+DEPEND="virtual/python"
+
+DOCS="${PYTHON_MODNAME}/README"
+S="${WORKDIR}/${MY_P}/src"
+
+pkg_setup() {
+ # check for Tkinter support in python
+ distutils_python_tkinter
+}
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}/${P}-install-no-docs.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ local DIR
+ DIR="${S}/${PYTHON_MODNAME}/Pmw_1_3"
+
+ if use doc; then
+ dohtml -a html,gif,py "${DIR}"/doc/* \
+ || die "failed to install docs"
+ fi
+
+ if use examples; then
+ insinto "${ROOT}/usr/share/doc/${PF}/examples"
+ doins "${DIR}"/demos/* \
+ || die "failed to install demos"
+ fi
+
+ #Tests are not unittests and show various
+ #GUIs. So we don't run them in the ebuild
+
+}
+