summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-09-04 21:31:09 +0000
committerTim Harder <radhermit@gentoo.org>2014-09-04 21:31:09 +0000
commit4c6f12f56284ad53fced54ad38aec34aa0afcd73 (patch)
tree20562827226dfab658c8d6b732a9fc1881c2a32f /dev-python/netifaces
parentold (diff)
downloadgentoo-2-4c6f12f56284ad53fced54ad38aec34aa0afcd73.tar.gz
gentoo-2-4c6f12f56284ad53fced54ad38aec34aa0afcd73.tar.bz2
gentoo-2-4c6f12f56284ad53fced54ad38aec34aa0afcd73.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/netifaces')
-rw-r--r--dev-python/netifaces/ChangeLog8
-rw-r--r--dev-python/netifaces/files/netifaces-0.10.4-remove-osx-fix.patch15
-rw-r--r--dev-python/netifaces/netifaces-0.10.4.ebuild23
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/netifaces/ChangeLog b/dev-python/netifaces/ChangeLog
index cfcea4e1edb9..14c98948da51 100644
--- a/dev-python/netifaces/ChangeLog
+++ b/dev-python/netifaces/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/netifaces
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/ChangeLog,v 1.18 2014/06/06 09:04:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/ChangeLog,v 1.19 2014/09/04 21:31:09 radhermit Exp $
+
+*netifaces-0.10.4 (04 Sep 2014)
+
+ 04 Sep 2014; Tim Harder <radhermit@gentoo.org> +netifaces-0.10.4.ebuild,
+ +files/netifaces-0.10.4-remove-osx-fix.patch:
+ Version bump.
06 Jun 2014; Sergey Popov <pinkbyte@gentoo.org> -netifaces-0.8.ebuild,
-netifaces-0.8-r1.ebuild:
diff --git a/dev-python/netifaces/files/netifaces-0.10.4-remove-osx-fix.patch b/dev-python/netifaces/files/netifaces-0.10.4-remove-osx-fix.patch
new file mode 100644
index 000000000000..7f87a02e365a
--- /dev/null
+++ b/dev-python/netifaces/files/netifaces-0.10.4-remove-osx-fix.patch
@@ -0,0 +1,15 @@
+--- netifaces-0.10.4/setup.py
++++ netifaces-0.10.4/setup.py
+@@ -18,12 +18,6 @@
+
+ __version__ = "0.10.4"
+
+-# Disable hard links, otherwise building distributions fails on OS X
+-try:
+- del os.link
+-except:
+- pass
+-
+ # On Windows, we need ws2_32 and iphlpapi
+ if getattr(sys, 'getwindowsversion', None):
+ libraries = ['ws2_32', 'iphlpapi']
diff --git a/dev-python/netifaces/netifaces-0.10.4.ebuild b/dev-python/netifaces/netifaces-0.10.4.ebuild
new file mode 100644
index 000000000000..89879072c3da
--- /dev/null
+++ b/dev-python/netifaces/netifaces-0.10.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netifaces/netifaces-0.10.4.ebuild,v 1.1 2014/09/04 21:31:09 radhermit Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Portable network interface information"
+HOMEPAGE="http://alastairs-place.net/netifaces/ https://pypi.python.org/pypi/netifaces/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-remove-osx-fix.patch )