summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-18 15:54:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-18 15:54:06 +0000
commit29b1603b3cb680b7cc36c2d1f01fddebc1c65c11 (patch)
tree5588930c075d052295221a22abda17215a9a27f7 /dev-python/mechanize
parentDelete older ebuilds. (diff)
downloadgentoo-2-29b1603b3cb680b7cc36c2d1f01fddebc1c65c11.tar.gz
gentoo-2-29b1603b3cb680b7cc36c2d1f01fddebc1c65c11.tar.bz2
gentoo-2-29b1603b3cb680b7cc36c2d1f01fddebc1c65c11.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mechanize')
-rw-r--r--dev-python/mechanize/ChangeLog9
-rw-r--r--dev-python/mechanize/mechanize-0.2.2.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index f18b7febafaa..5ba5b5575c77 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/mechanize
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.26 2010/07/18 13:48:23 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.27 2010/07/18 15:54:06 arfrever Exp $
+
+*mechanize-0.2.2 (18 Jul 2010)
+
+ 18 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -mechanize-0.1.11.ebuild, -files/mechanize-0.1.11-python-2.7.patch,
+ -mechanize-0.2.0.ebuild, +mechanize-0.2.2.ebuild:
+ Version bump.
18 Jul 2010; <nixnut@gentoo.org> mechanize-0.2.1.ebuild:
ppc stable #324475
diff --git a/dev-python/mechanize/mechanize-0.2.2.ebuild b/dev-python/mechanize/mechanize-0.2.2.ebuild
new file mode 100644
index 000000000000..fc91b0199303
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.2.ebuild,v 1.1 2010/07/18 15:54:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="docs/*.txt"
+
+src_test() {
+ testing() {
+ # Ignore warnings (http://github.com/jjlee/mechanize/issues/issue/13).
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" -Wignore test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ # Fix some paths.
+ sed -i -e 's:../styles/:styles/:g' docs/html/*
+ dohtml -r docs/html/ docs/styles
+
+ distutils_src_install
+}