summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-12 00:16:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-12 00:16:50 +0000
commita002695fbe3c6662acc135180028345852b3e4e2 (patch)
tree30340a6b426f16bd4a0c0e4b7fc442317baa5597 /dev-python/logbook
parentVersion bump to 1.8.0. (diff)
downloadgentoo-2-a002695fbe3c6662acc135180028345852b3e4e2.tar.gz
gentoo-2-a002695fbe3c6662acc135180028345852b3e4e2.tar.bz2
gentoo-2-a002695fbe3c6662acc135180028345852b3e4e2.zip
bump; update test phase, closes Bug #503612 by eroen
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/logbook')
-rw-r--r--dev-python/logbook/ChangeLog7
-rw-r--r--dev-python/logbook/logbook-0.6.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index d9d3a1dbe280..4f1c69bb29a0 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.15 2014/03/31 20:46:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.16 2014/04/12 00:16:50 idella4 Exp $
+
+*logbook-0.6.0 (12 Apr 2014)
+
+ 12 Apr 2014; Ian Delaney <idella4@gentoo.org> +logbook-0.6.0.ebuild:
+ bump; update test phase, closes Bug #503612 by eroen
31 Mar 2014; Michał Górny <mgorny@gentoo.org> logbook-0.5.0.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/logbook/logbook-0.6.0.ebuild b/dev-python/logbook/logbook-0.6.0.ebuild
new file mode 100644
index 000000000000..1cfb8aad0f9a
--- /dev/null
+++ b/dev-python/logbook/logbook-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.6.0.ebuild,v 1.1 2014/04/12 00:16:50 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/mitsuhiko/logbook/issues/101
+ if python_is_python3; then
+ nosetests -e test_mail_handler -w tests || die "Tests failed under ${EPYTHON}"
+ else
+ nosetests -w tests || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}