summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-26 04:46:18 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-26 04:46:18 +0000
commitd09cacb4847a830072ddcc1c8d66533ca8a75933 (patch)
tree23ee15010b8cd6769bb7eafcdfc468ef9d25465c /dev-python/lesscpy
parentAdd maintainer name. (diff)
downloadgentoo-2-d09cacb4847a830072ddcc1c8d66533ca8a75933.tar.gz
gentoo-2-d09cacb4847a830072ddcc1c8d66533ca8a75933.tar.bz2
gentoo-2-d09cacb4847a830072ddcc1c8d66533ca8a75933.zip
bump; add py3 support, substitute and update test phase, upstream bug cited in comment
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/lesscpy')
-rw-r--r--dev-python/lesscpy/ChangeLog8
-rw-r--r--dev-python/lesscpy/lesscpy-0.10.2.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/lesscpy/ChangeLog b/dev-python/lesscpy/ChangeLog
index 679bd81222a4..b89e1837423b 100644
--- a/dev-python/lesscpy/ChangeLog
+++ b/dev-python/lesscpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/lesscpy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lesscpy/ChangeLog,v 1.5 2015/06/03 20:04:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lesscpy/ChangeLog,v 1.6 2015/06/26 04:46:18 idella4 Exp $
+
+*lesscpy-0.10.2 (26 Jun 2015)
+
+ 26 Jun 2015; Ian Delaney <idella4@gentoo.org> +lesscpy-0.10.2.ebuild:
+ bump; add py3 support, substitute and update test phase, upstream bug cited in
+ comment
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/lesscpy/lesscpy-0.10.2.ebuild b/dev-python/lesscpy/lesscpy-0.10.2.ebuild
new file mode 100644
index 000000000000..75d39005c227
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lesscpy/lesscpy-0.10.2.ebuild,v 1.1 2015/06/26 04:46:18 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/lesscpy/lesscpy/issues/74
+ esetup.py test
+ # This is equally effective
+ # nosetests -v || die "tests failed under ${EPYTHON}"
+}