summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-26 13:11:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-26 13:11:24 +0000
commit2334dc579d88d6e39bf53d8961ec9d9bd7686de6 (patch)
tree66878eb7f04d65f1033a40f899910a1fef650e97 /dev-python/jsmin/jsmin-2.0.9.ebuild
parentVersion bump - bug #503184 (diff)
downloadgentoo-2-2334dc579d88d6e39bf53d8961ec9d9bd7686de6.tar.gz
gentoo-2-2334dc579d88d6e39bf53d8961ec9d9bd7686de6.tar.bz2
gentoo-2-2334dc579d88d6e39bf53d8961ec9d9bd7686de6.zip
bump; add py3.4 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/jsmin/jsmin-2.0.9.ebuild')
-rw-r--r--dev-python/jsmin/jsmin-2.0.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jsmin/jsmin-2.0.9.ebuild b/dev-python/jsmin/jsmin-2.0.9.ebuild
new file mode 100644
index 000000000000..d11079adb518
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsmin/jsmin-2.0.9.ebuild,v 1.1 2014/04/26 13:11:24 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ "${PYTHON}" -m ${PN}.test || die
+ popd > /dev/null
+}