summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-12-12 16:02:58 +0000
committerAli Polatel <hawking@gentoo.org>2007-12-12 16:02:58 +0000
commit9c09ee457bb2b46605b690d0a4fca783e8afd536 (patch)
tree1699ae2940bf22c0ad815d8e4e59b0f98efb6113 /dev-python/ipython
parentStable for HPPA. (diff)
downloadgentoo-2-9c09ee457bb2b46605b690d0a4fca783e8afd536.tar.gz
gentoo-2-9c09ee457bb2b46605b690d0a4fca783e8afd536.tar.bz2
gentoo-2-9c09ee457bb2b46605b690d0a4fca783e8afd536.zip
Version bump, modified emacs depend for emacs-22
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog7
-rw-r--r--dev-python/ipython/files/digest-ipython-0.8.23
-rw-r--r--dev-python/ipython/ipython-0.8.2.ebuild74
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 91e5dd032f06..50ec5fd87657 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ipython
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.42 2007/10/24 17:20:06 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.43 2007/12/12 16:02:57 hawking Exp $
+
+*ipython-0.8.2 (12 Dec 2007)
+
+ 12 Dec 2007; Ali Polatel <hawking@gentoo.org> +ipython-0.8.2.ebuild:
+ Version bump, modified emacs depend for emacs-22
*ipython-0.8.1-r1 (24 Oct 2007)
diff --git a/dev-python/ipython/files/digest-ipython-0.8.2 b/dev-python/ipython/files/digest-ipython-0.8.2
new file mode 100644
index 000000000000..90078d7260a1
--- /dev/null
+++ b/dev-python/ipython/files/digest-ipython-0.8.2
@@ -0,0 +1,3 @@
+MD5 fd5a1b6e518898a4aee8b8d8b428af70 ipython-0.8.2.tar.gz 1172098
+RMD160 976d8512d68ed4e1bf28ab50e90bcb7777c34e53 ipython-0.8.2.tar.gz 1172098
+SHA256 cc673c7cdef38f7ab21ee22e7be5a591b6b6eda590b82f71a74ff8b5103831c4 ipython-0.8.2.tar.gz 1172098
diff --git a/dev-python/ipython/ipython-0.8.2.ebuild b/dev-python/ipython/ipython-0.8.2.ebuild
new file mode 100644
index 000000000000..b30eebdc84f6
--- /dev/null
+++ b/dev-python/ipython/ipython-0.8.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.8.2.ebuild,v 1.1 2007/12/12 16:02:57 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils elisp-common
+
+DESCRIPTION="An advanced interactive shell for Python."
+HOMEPAGE="http://ipython.scipy.org/"
+SRC_URI="http://ipython.scipy.org/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE="doc examples emacs gnuplot"
+
+RDEPEND="gnuplot? ( dev-python/gnuplot-py )
+ emacs? ( || ( app-emacs/python-mode
+ >=virtual/emacs-22 ) )
+ dev-python/pexpect"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="IPython"
+SITEFILE="62ipython-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/examfiles/d' -e '/examples/d' \
+ -e "/'manual'/d" -e '/manfiles)/d' \
+ -e 's/^docfiles.*/docfiles=""/' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs ; then
+ cd doc
+ elisp-comp ipython.el || die "elisp-comp failed"
+ fi
+}
+
+src_install() {
+ DOCS="doc/ChangeLog"
+ distutils_src_install
+
+ cd doc
+ insinto /usr/share/doc/${PF}
+
+ if use doc ; then
+ dohtml manual/*
+ doins *.pdf
+ fi
+ if use examples ; then
+ doins -r examples
+ fi
+ if use emacs ; then
+ elisp-install ${PN} ipython.el ipython.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}